summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2020-12-26 15:29:22 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-01-10 23:14:09 -0500
commit5c6ef32f59b92a1c1ff4636a413b6d3fe6208145 (patch)
tree6cffffb6f4eda8b4735e55977dd4524cc189b3bc
parenteafa48b2398fc80f60d17483e44d6080a28efc23 (diff)
downloadmeta-cloud-services-5c6ef32f59b92a1c1ff4636a413b6d3fe6208145.tar.gz
json: fix Bignumn/Fixnum issue when using Ruby 2.5
There is a recognized problem with json_1.8.3 when used with Ruby 2.5; in summary: compiling generator.c generator.c: In function ‘generate_json’: generator.c:861:25: error: ‘rb_cFixnum’ undeclared (first use in this function); did you mean ‘mFixnum’? } else if (klass == rb_cFixnum) { ^~~~~~~~~~ mFixnum generator.c:861:25: note: each undeclared identifier is reported only once for each function it appears in generator.c:863:25: error: ‘rb_cBignum’ undeclared (first use in this function); did you mean ‘rb_cFixnum’? } else if (klass == rb_cBignum) { ^~~~~~~~~~ rb_cFixnum This is explained in detail at: https://makandracards.com/makandra/74544-how-to-fix-json-1-8-3-with-ruby-2-5 The simplest solution is to upgrade json just a wee bit to 1.8.5 to resolve this. Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/ruby/json_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/json_git.bb b/meta-openstack/recipes-devtools/ruby/json_git.bb
index a417798..f7b3dd7 100644
--- a/meta-openstack/recipes-devtools/ruby/json_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/json_git.bb
@@ -5,18 +5,18 @@ SUMMARY = "An implementation of the JSON specification according to RFC 4627"
5DESCRIPTION = "An implementation of the JSON specification according to RFC 4627" 5DESCRIPTION = "An implementation of the JSON specification according to RFC 4627"
6 6
7LICENSE = "GPLv2" 7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=aef161fe3c86f1a8d6c71d3b8c5655c5" 8LIC_FILES_CHKSUM = "file://CHANGES;md5=af8cad0ff27a1593ac5ee461bc2d71ab"
9 9
10PR = "r0" 10PR = "r0"
11 11
12BPV = "1.8.3" 12BPV = "1.8.5"
13PV = "${BPV}" 13PV = "${BPV}"
14SRCREV = "db4c71a7701b95c30f945ee1536240920dcfdc17" 14SRCREV = "4cf6c6270f52888997ec1b626b9f557db4f26f2e"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18SRC_URI = " \ 18SRC_URI = " \
19 git://github.com/flori/json.git \ 19 git://github.com/flori/json.git;branch=v1.8 \
20 " 20 "
21 21
22inherit ruby 22inherit ruby