summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-11-14 23:14:40 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-14 23:14:40 -0500
commit5540933a070b1873735d4ce6bc730e5717c8d8f2 (patch)
treef2ff7ecda8b0cc0e2740054ff03e343848e24099
parent9175f5b7a6d0ecfe82f908abb1cda233fcab4296 (diff)
downloadmeta-cloud-services-5540933a070b1873735d4ce6bc730e5717c8d8f2.tar.gz
cloud-init: remove recipe
Support has been moved to meta-virt, so we drop this older recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init/cloud-init-source-local-lsb-functions.patch64
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init/cloud.cfg99
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init/distros-add-windriver-skeleton-distro-file.patch44
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb53
4 files changed, 0 insertions, 260 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud-init-source-local-lsb-functions.patch b/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud-init-source-local-lsb-functions.patch
deleted file mode 100644
index 869fb31..0000000
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud-init-source-local-lsb-functions.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1From 72dd3b4b38705442d821fe97a40061f23e748769 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Thu, 6 Mar 2014 01:55:09 -0500
4Subject: [PATCH] cloud-init: source local lsb functions
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
7---
8 sysvinit/debian/cloud-config | 1 +
9 sysvinit/debian/cloud-final | 1 +
10 sysvinit/debian/cloud-init | 1 +
11 sysvinit/debian/cloud-init-local | 1 +
12 4 files changed, 4 insertions(+)
13
14diff --git a/sysvinit/debian/cloud-config b/sysvinit/debian/cloud-config
15index 53322748ac65..7874dcfab9b0 100644
16--- a/sysvinit/debian/cloud-config
17+++ b/sysvinit/debian/cloud-config
18@@ -30,6 +30,7 @@ SCRIPTNAME=/etc/init.d/$NAME
19 # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
20 # and status_of_proc is working.
21 . /lib/lsb/init-functions
22+. /etc/init.d/functions
23
24 if init_is_upstart; then
25 case "$1" in
26diff --git a/sysvinit/debian/cloud-final b/sysvinit/debian/cloud-final
27index 55afc8b0678a..661314f0b64c 100644
28--- a/sysvinit/debian/cloud-final
29+++ b/sysvinit/debian/cloud-final
30@@ -32,6 +32,7 @@ SCRIPTNAME=/etc/init.d/$NAME
31 # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
32 # and status_of_proc is working.
33 . /lib/lsb/init-functions
34+. /etc/init.d/functions
35
36 if init_is_upstart; then
37 case "$1" in
38diff --git a/sysvinit/debian/cloud-init b/sysvinit/debian/cloud-init
39index 48fa04233f00..d3ccec99bacc 100755
40--- a/sysvinit/debian/cloud-init
41+++ b/sysvinit/debian/cloud-init
42@@ -30,6 +30,7 @@ SCRIPTNAME=/etc/init.d/$NAME
43 # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
44 # and status_of_proc is working.
45 . /lib/lsb/init-functions
46+. /etc/init.d/functions
47
48 if init_is_upstart; then
49 case "$1" in
50diff --git a/sysvinit/debian/cloud-init-local b/sysvinit/debian/cloud-init-local
51index 802ee8e9f386..c309e8347324 100644
52--- a/sysvinit/debian/cloud-init-local
53+++ b/sysvinit/debian/cloud-init-local
54@@ -29,6 +29,7 @@ SCRIPTNAME=/etc/init.d/$NAME
55 # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
56 # and status_of_proc is working.
57 . /lib/lsb/init-functions
58+. /etc/init.d/functions
59
60 if init_is_upstart; then
61 case "$1" in
62--
631.7.10.4
64
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud.cfg b/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud.cfg
deleted file mode 100644
index f868936..0000000
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init/cloud.cfg
+++ /dev/null
@@ -1,99 +0,0 @@
1# The top level settings are used as module
2# and system configuration.
3
4# A set of users which may be applied and/or used by various modules
5# when a 'default' entry is found it will reference the 'default_user'
6# from the distro configuration specified below
7users:
8 - default
9
10# If this is set, 'root' will not be able to ssh in and they
11# will get a message to login instead as the above $user (ubuntu)
12disable_root: False
13
14# This will cause the set+update hostname module to not operate (if true)
15preserve_hostname: false
16manage_etc_hosts: %MANAGE_HOSTS%
17
18datasource_list:
19 - None
20
21# Example datasource config
22# datasource:
23# Ec2:
24# metadata_urls: [ 'blah.com' ]
25# timeout: 5 # (defaults to 50 seconds)
26# max_wait: 10 # (defaults to 120 seconds)
27
28# The modules that run in the 'init' stage
29cloud_init_modules:
30 - migrator
31 - seed_random
32 - bootcmd
33 - write-files
34 - growpart
35 - set_hostname
36 - update_hostname
37 - update_etc_hosts
38 - ca-certs
39 - rsyslog
40 - users-groups
41 - ssh
42
43# The modules that run in the 'config' stage
44cloud_config_modules:
45# Emit the cloud config ready event
46# this can be used by upstart jobs for 'start on cloud-config'.
47 - emit_upstart
48 - disk_setup
49 - mounts
50 - ssh-import-id
51 - locale
52 - set-passwords
53 - grub-dpkg
54 - apt-pipelining
55 - apt-configure
56 - package-update-upgrade-install
57 - landscape
58 - timezone
59 - puppet
60 - chef
61 - salt-minion
62 - mcollective
63 - disable-ec2-metadata
64 - runcmd
65 - byobu
66
67# The modules that run in the 'final' stage
68cloud_final_modules:
69 - rightscale_userdata
70 - scripts-per-once
71 - scripts-per-boot
72 - scripts-per-instance
73 - scripts-user
74 - ssh-authkey-fingerprints
75 - keys-to-console
76 - phone-home
77 - final-message
78 - power-state-change
79
80# set the hostname
81hostname: %HOSTNAME%
82
83# System and/or distro specific settings
84# (not accessible to handlers/transforms)
85system_info:
86 # This will affect which distro class gets used
87 distro: windriver
88 # Default user name + that default users groups (if added/used)
89 default_user:
90 name: root
91 lock_passwd: False
92 groups: [adm, audio, cdrom, dialout, dip, floppy, netdev, plugdev, sudo, video]
93 sudo: ["ALL=(ALL) NOPASSWD:ALL"]
94 shell: /bin/bash
95 # Other config here will be given to the distro class and/or path classes
96 paths:
97 cloud_dir: /var/lib/cloud/
98 templates_dir: /etc/cloud/templates/
99 ssh_svcname: ssh
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init/distros-add-windriver-skeleton-distro-file.patch b/meta-openstack/recipes-extended/cloud-init/cloud-init/distros-add-windriver-skeleton-distro-file.patch
deleted file mode 100644
index f52faf3..0000000
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init/distros-add-windriver-skeleton-distro-file.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 6ad7caf6410237f3b1bed6ff4d9f0423e69afcd6 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Mon, 10 Mar 2014 00:57:18 -0400
4Subject: [PATCH] distros: add windriver skeleton distro file
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
7---
8 cloudinit/distros/windriver.py | 24 ++++++++++++++++++++++++
9 1 file changed, 24 insertions(+)
10 create mode 100644 cloudinit/distros/windriver.py
11
12diff --git a/cloudinit/distros/windriver.py b/cloudinit/distros/windriver.py
13new file mode 100644
14index 000000000000..8eec13fe2207
15--- /dev/null
16+++ b/cloudinit/distros/windriver.py
17@@ -0,0 +1,24 @@
18+# vi: ts=4 expandtab
19+#
20+# Copyright (C) 2014 WindRiver
21+#
22+# This program is free software: you can redistribute it and/or modify
23+# it under the terms of the GNU General Public License version 3, as
24+# published by the Free Software Foundation.
25+#
26+# This program is distributed in the hope that it will be useful,
27+# but WITHOUT ANY WARRANTY; without even the implied warranty of
28+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29+# GNU General Public License for more details.
30+#
31+# You should have received a copy of the GNU General Public License
32+# along with this program. If not, see <http://www.gnu.org/licenses/>.
33+
34+from cloudinit.distros import debian
35+from cloudinit import log as logging
36+
37+LOG = logging.getLogger(__name__)
38+
39+
40+class Distro(debian.Distro):
41+ pass
42--
431.7.10.4
44
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
deleted file mode 100644
index 8bbbef1..0000000
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1DESCRIPTION = "Init scripts for use on cloud images"
2HOMEPAGE = "https://launchpad.net/cloud-init"
3SECTION = "devel/python"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
6
7PR = "r0"
8
9SRC_URI = "https://launchpad.net/cloud-init/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \
10 file://cloud-init-source-local-lsb-functions.patch \
11 file://distros-add-windriver-skeleton-distro-file.patch \
12 file://cloud.cfg"
13
14SRC_URI[md5sum] = "cd392e943dd0165e90a6d56afd0e4ad3"
15SRC_URI[sha256sum] = "9e8fd22eb7f6e40ae6a5f66173ddc3cc18f65ee406c460a728092b37db2f3ed7"
16
17S = "${WORKDIR}/${BPN}-${PV}"
18
19DISTUTILS_INSTALL_ARGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '--init-system=sysvinit_deb', '', d)}"
20DISTUTILS_INSTALL_ARGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--init-system=systemd', '', d)}"
21
22MANAGE_HOSTS ?= "False"
23HOSTNAME ?= ""
24
25do_install_prepend() {
26 sed -e 's:/lib/${BPN}:${base_libdir}/${BPN}:' -i ${S}/setup.py
27}
28
29do_install_append() {
30 install -m 0755 ${WORKDIR}/cloud.cfg ${D}${sysconfdir}/cloud/cloud.cfg
31
32 sed -e "s:%MANAGE_HOSTS%:${MANAGE_HOSTS}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg
33 sed -e "s:%HOSTNAME%:${HOSTNAME}:g" -i ${D}${sysconfdir}/cloud/cloud.cfg
34
35 ln -s ${libdir}/${BPN}/uncloud-init ${D}${sysconfdir}/cloud/uncloud-init
36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
37}
38
39inherit setuptools3 update-rc.d
40
41PACKAGES += "${PN}-systemd"
42
43FILES_${PN} += "${sysconfdir}/* \
44 ${datadir}/*"
45
46FILES_${PN}-systemd += "${systemd_unitdir}/*"
47
48INITSCRIPT_PACKAGES = "${PN}"
49INITSCRIPT_NAME_${BPN} = "cloud-init"
50
51RDEPENDS_${PN} = "sysklogd \
52 python3 \
53 "