summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihai Prica <prica.mihai@gmail.com>2013-07-23 10:56:00 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:59 -0400
commit526a965c33fb8fca5e7b2492c91645f9d8cb8ea3 (patch)
tree215c353e24b87d5b225353af591f1a69722ee41f
parent6e5110f45799bc63ee15e75ce127837e6ec36811 (diff)
downloadmeta-cloud-services-526a965c33fb8fca5e7b2492c91645f9d8cb8ea3.tar.gz
python-horizon: Fix bindir search path
An error occurs because horizon searches for lessc in /usr/lib/python2.7/site-packages/bin while this is installed in /usr/share/bin. Signed-off-by: Mihai Prica <prica.mihai@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon/fix_bindir_path.patch15
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_2013.1.2.bb3
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon/fix_bindir_path.patch b/meta-openstack/recipes-devtools/python/python-horizon/fix_bindir_path.patch
new file mode 100644
index 0000000..c9d0b1a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-horizon/fix_bindir_path.patch
@@ -0,0 +1,15 @@
1Upstream-Status: Inappropriate [configuration]
2
3Index: horizon-2013.1.2/openstack_dashboard/settings.py
4===================================================================
5--- horizon-2013.1.2.orig/openstack_dashboard/settings.py
6+++ horizon-2013.1.2/openstack_dashboard/settings.py
7@@ -29,7 +29,7 @@ warnings.formatwarning = lambda message,
8 '%s: %s' % (category.__name__, message)
9
10 ROOT_PATH = os.path.dirname(os.path.abspath(__file__))
11-BIN_DIR = os.path.abspath(os.path.join(ROOT_PATH, '..', 'bin'))
12+BIN_DIR = os.path.abspath(os.path.join(ROOT_PATH, 'bin'))
13
14 if ROOT_PATH not in sys.path:
15 sys.path.append(ROOT_PATH)
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_2013.1.2.bb b/meta-openstack/recipes-devtools/python/python-horizon_2013.1.2.bb
index 5e222db..fcf3e38 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_2013.1.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_2013.1.2.bb
@@ -25,6 +25,7 @@ SRCNAME = "horizon"
25 25
26SRC_URI = "https://launchpad.net/horizon/grizzly/${PV}/+download/${SRCNAME}-${PV}.tar.gz \ 26SRC_URI = "https://launchpad.net/horizon/grizzly/${PV}/+download/${SRCNAME}-${PV}.tar.gz \
27 file://horizon.init \ 27 file://horizon.init \
28 file://fix_bindir_path.patch \
28 " 29 "
29 30
30SRC_URI[md5sum] = "23db8455f768c830485ef283c06f0e65" 31SRC_URI[md5sum] = "23db8455f768c830485ef283c06f0e65"
@@ -51,6 +52,8 @@ do_install_append() {
51 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' ${WORKDIR}/horizon.init >${WORKDIR}/horizon 52 sed 's:@PYTHON_SITEPACKAGES@:${PYTHON_SITEPACKAGES_DIR}:' ${WORKDIR}/horizon.init >${WORKDIR}/horizon
52 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon 53 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon
53 fi 54 fi
55
56 mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin
54} 57}
55 58
56PACKAGES += "${SRCNAME}" 59PACKAGES += "${SRCNAME}"