summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-11-23 22:51:41 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:27:22 -0500
commit4c7f835e85722af1f99e703148968c881e94359f (patch)
tree62fb0b5be7eb3e83a4dcb4938d62e922e6dbaa32
parent80183e4e9c1a22b7212daaf6496a7ab56d3a3b71 (diff)
downloadmeta-cloud-services-4c7f835e85722af1f99e703148968c881e94359f.tar.gz
python3-munch: Add recipe
Append python3-munch because it is dependent on python3-openstacksdk runtime. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python3-munch_2.5.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-munch_2.5.0.bb b/meta-openstack/recipes-devtools/python/python3-munch_2.5.0.bb
new file mode 100644
index 0000000..58f40d0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-munch_2.5.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "munch is a fork of David Schoonover's Bunch package, providing similar functionality"
2HOMEPAGE = "https://pypi.org/project/munch/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f0291cd32b2d6a91d9b19970c94d0a46"
6
7SRC_URI[md5sum] = "ed84c3718416c8d4d03d0a6ef46e8e0c"
8SRC_URI[sha256sum] = "2d735f6f24d4dba3417fa448cae40c6e896ec1fdab6cdb5e6510999758a4dbd2"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pbr-native \
14"
15
16RDEPENDS_${PN} += " \
17 python3-pkg-resources \
18 python3-six \
19"