summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-02-28 09:11:06 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 14:17:46 -0400
commit4becb19947677a19976e73f8372c8964769ef50f (patch)
tree103fc48cae5f4b8ffa51e420b00f8118e3ea25f4
parent837241fa91dd2d81850526580cd560fb6550c7b8 (diff)
downloadmeta-cloud-services-4becb19947677a19976e73f8372c8964769ef50f.tar.gz
linux-yocto_3.10: to include iscsi-tcp cfg
In order for Libvirt compute node to be able to mount Cinder LVM backend driver volume (hosted by Cinder Volume service) over iscsi, the initiator iscsi kernel-module is needed. This patch simplies to add kernel cfg for turning on iscsi-tcp kernel config. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/enable-iscsi-tcp.cfg3
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto/iscsi-tcp.scc4
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend6
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/enable-iscsi-tcp.cfg b/meta-openstack/recipes-kernel/linux/linux-yocto/enable-iscsi-tcp.cfg
new file mode 100644
index 0000000..9f019e5
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/enable-iscsi-tcp.cfg
@@ -0,0 +1,3 @@
1CONFIG_SCSI_ISCSI_ATTRS=m
2CONFIG_ISCSI_TCP=m
3CONFIG_ISCSI_BOOT_SYSFS=m
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto/iscsi-tcp.scc b/meta-openstack/recipes-kernel/linux/linux-yocto/iscsi-tcp.scc
new file mode 100644
index 0000000..66dfb34
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto/iscsi-tcp.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Enable tcp iscsi initiator"
2define KFEATURE_COMPATIBILITY board
3
4kconf non-hardware enable-iscsi-tcp.cfg
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 0000000..2d7c60f
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PRINC := "${@int(PRINC) + 1}"
3
4SRC_URI += "file://iscsi-tcp.scc \
5 file://enable-iscsi-tcp.cfg \
6 "