summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-12-15 15:22:36 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-21 17:16:13 -0500
commit4a907e91e8e81e4c5505e784037a78b7872bc4ed (patch)
tree070d39dc2b14ce39c4f8b590a5dea23097d582d5
parent7ef8fbfab8ced12e291e8579d39e913cda25c3ab (diff)
downloadmeta-cloud-services-4a907e91e8e81e4c5505e784037a78b7872bc4ed.tar.gz
python3-osprofiler: upgrade 2.9.0 -> 3.4.0
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-osprofiler_2.9.0.bb35
-rw-r--r--meta-openstack/recipes-devtools/python/python3-osprofiler_3.4.0.bb35
2 files changed, 35 insertions, 35 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osprofiler_2.9.0.bb b/meta-openstack/recipes-devtools/python/python-osprofiler_2.9.0.bb
deleted file mode 100644
index e6fe865..0000000
--- a/meta-openstack/recipes-devtools/python/python-osprofiler_2.9.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "OpenStack Profiler Library"
2HOMEPAGE = "http://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
6
7SRC_URI[md5sum] = "75f190b00ac248b3d547b67a480801db"
8SRC_URI[sha256sum] = "6915cbf8ac390dc3e125340b0ff368dd53f5889e3d053f9122dd83ba0dd366f7"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python-pip \
16 python-pbr \
17 "
18
19# Satisfy setup.py 'setup_requires'
20DEPENDS += " \
21 python-pbr-native \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python-pbr \
27 python-six \
28 python-oslo.messaging \
29 python-oslo.log \
30 python-oslo.utils \
31 python-webob \
32 python-requests \
33 python-netaddr \
34 python-oslo.concurrency \
35 "
diff --git a/meta-openstack/recipes-devtools/python/python3-osprofiler_3.4.0.bb b/meta-openstack/recipes-devtools/python/python3-osprofiler_3.4.0.bb
new file mode 100644
index 0000000..5d7939b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-osprofiler_3.4.0.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "OpenStack Profiler Library"
2HOMEPAGE = "http://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
6
7SRC_URI[md5sum] = "691c4d2cc77e60eeaa30edd7bf087481"
8SRC_URI[sha256sum] = "f7fe387f4dd681bbf92b9fbe857cc90e89cfe96d44522a2727540902310a9ed6"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python3-pip \
16 python3-pbr \
17 "
18
19# Satisfy setup.py 'setup_requires'
20DEPENDS += " \
21 python3-pbr-native \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python3-pbr \
27 python3-six \
28 python3-oslo.messaging \
29 python3-oslo.log \
30 python3-oslo.utils \
31 python3-webob \
32 python3-requests \
33 python3-netaddr \
34 python3-oslo.concurrency \
35 "