summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-04-11 14:01:29 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-15 19:49:52 -0400
commit496304e28096f01657d1160507b1df4bf50d538f (patch)
treeb568519f38999c1135ff0e5fee918d0fd15b2c52
parentc533b15bb52825f9062d2c7b7e945fb6205c7503 (diff)
downloadmeta-cloud-services-496304e28096f01657d1160507b1df4bf50d538f.tar.gz
OpenStack: all-in-one node
Introduce image openstack-image-aio, integrating both compute and controller functionality Signed-off-by: Amy Fong <amy.fong@windriver.com>
-rw-r--r--meta-openstack-aio-deploy/README48
-rw-r--r--meta-openstack-aio-deploy/classes/hosts.bbclass17
-rw-r--r--meta-openstack-aio-deploy/conf/layer.conf10
-rw-r--r--meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend1
-rw-r--r--meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb (renamed from meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb)0
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-aio.bb29
6 files changed, 105 insertions, 0 deletions
diff --git a/meta-openstack-aio-deploy/README b/meta-openstack-aio-deploy/README
new file mode 100644
index 0000000..3603739
--- /dev/null
+++ b/meta-openstack-aio-deploy/README
@@ -0,0 +1,48 @@
1meta-openstack-aio-deploy
2=============================
3
4This layer provides support configuring and deploying the recipes to create an
5all-in-one compute/controller node.
6
7Dependencies
8------------
9
10This layer depends on:
11
12URI: git://github.com/openembedded/oe-core.git
13branch: master
14revision: HEAD
15prio: default
16
17URI: git://github.com/openembedded/meta-oe.git
18patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
19revision: HEAD
20layers: meta-oe
21 meta-networking
22 meta-ruby
23
24URI: git://git.yoctoproject.org/meta-virtualization
25branch: master
26revision: head
27
28meta-openstack
29branch: master
30revision: head
31
32Maintenance
33-----------
34
35Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
36
37When sending single patches, please using something like:
38'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
39
40Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
41
42License
43-------
44
45All metadata is MIT licensed unless otherwise stated. Source code included
46in tree for individual recipes is under the LICENSE stated in each recipe
47(.bb file) unless otherwise stated.
48
diff --git a/meta-openstack-aio-deploy/classes/hosts.bbclass b/meta-openstack-aio-deploy/classes/hosts.bbclass
new file mode 100644
index 0000000..82c9eb7
--- /dev/null
+++ b/meta-openstack-aio-deploy/classes/hosts.bbclass
@@ -0,0 +1,17 @@
1#
2# all-in-one hosts file
3#
4# The aio rootfs combines the functionality of the compute and
5# the controller in one node.
6#
7# The aio rootfs adds another hostname aio, since we need
8# ths hostname compute and controller for the system's functionality,
9# we defined compute and controller in this file as well.
10#
11COMPUTE_IP ?= "${CONTROLLER_IP}"
12COMPUTE_HOST ?= "compute"
13CONTROLLER_IP ?= "128.224.149.173"
14CONTROLLER_HOST ?= "controller"
15MY_IP ?= "${CONTROLLER_IP}"
16MY_HOST ?= "${CONTROLLER_HOST}"
17DB_DATADIR ?= "/etc/postgresql"
diff --git a/meta-openstack-aio-deploy/conf/layer.conf b/meta-openstack-aio-deploy/conf/layer.conf
new file mode 100644
index 0000000..d1d1f64
--- /dev/null
+++ b/meta-openstack-aio-deploy/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend ${LAYERDIR}/classes/*.bbclass"
6
7BBFILE_COLLECTIONS += "openstack-aio-deploy-layer"
8BBFILE_PATTERN_openstack-aio-deploy-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_openstack-aio-deploy-layer = "6"
10
diff --git a/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend b/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend
new file mode 100644
index 0000000..28b44ec
--- /dev/null
+++ b/meta-openstack-aio-deploy/recipes-devtools/python/python-neutron_git.bbappend
@@ -0,0 +1 @@
inherit hosts
diff --git a/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb b/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb
index 459628a..459628a 100644
--- a/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb
+++ b/meta-openstack/recipes-extended/guest-images/cirros_0.3.0.bb
diff --git a/meta-openstack/recipes-extended/images/openstack-image-aio.bb b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
new file mode 100644
index 0000000..57f4249
--- /dev/null
+++ b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Openstack all-in-one node image"
2LICENSE = "MIT"
3
4OPENSTACK_CONTROLLER_EXTRA_INSTALL ?= ""
5OPENSTACK_COMPUTE_EXTRA_INSTALL ?= ""
6OPENSTACK_AIO_EXTRA_INSTALL ?= ""
7
8IMAGE_INSTALL = " \
9 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
10 ${CORE_IMAGE_BASE_INSTALL} \
11 packagegroup-core-full-cmdline \
12 packagegroup-cloud-compute \
13 packagegroup-cloud-controller \
14 packagegroup-cloud-network \
15 packagegroup-cloud-debug \
16 packagegroup-cloud-extras \
17 ${OPENSTACK_CONTROLLER_EXTRA_INSTALL} \
18 ${OPENSTACK_COMPUTE_EXTRA_INSTALL} \
19 ${OPENSTACK_AIO_EXTRA_INSTALL} \
20 "
21
22IMAGE_FEATURES += "ssh-server-openssh"
23
24inherit core-image
25inherit openstack-base
26
27# check for 5G of free space, so we use 5G as a starting point.
28IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 5000000"
29