summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 14:22:25 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:33 -0500
commit4554541b7038f94b94a094560b21c43dead1d0ea (patch)
tree99ade04a6853fa7913ea1c212d696c59edabf971
parentd29fdda5bdcabd4a08d003444b5c759e62b10ddc (diff)
downloadmeta-cloud-services-4554541b7038f94b94a094560b21c43dead1d0ea.tar.gz
python-cephclient: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cephclient.inc26
-rw-r--r--meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb28
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cephclient_0.1.0.5.bb2
3 files changed, 30 insertions, 26 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cephclient.inc b/meta-openstack/recipes-devtools/python/python-cephclient.inc
new file mode 100644
index 0000000..e8e0d0a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cephclient.inc
@@ -0,0 +1,26 @@
1DESCRIPTION = "A client library in python for the Ceph REST API."
2HOMEPAGE = "https://github.com/dmsimard/python-cephclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PYPI_PACKAGE = "python-cephclient"
8PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-v${PV}.tar.gz"
9
10SRC_URI[md5sum] = "e3746607f1af1573a241b4995c10c938"
11SRC_URI[sha256sum] = "9776b786da2aebdc0439ea2f809cc8923f52bc0cf610f77a9c1348466961134b"
12
13inherit pypi
14
15# DEPENDS_default: python-pip
16
17DEPENDS += " \
18 ${PYTHON_PN}-pip \
19 "
20
21# RDEPENDS_default:
22RDEPENDS_${PN} += " \
23 ${PYTHON_PN}-lxml \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-cython \
26 "
diff --git a/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
index 7ce7307..b3d7ca7 100644
--- a/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
+++ b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.5.bb
@@ -1,26 +1,2 @@
1DESCRIPTION = "A client library in python for the Ceph REST API." 1require python-cephclient.inc
2HOMEPAGE = "https://github.com/dmsimard/python-cephclient" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PYPI_PACKAGE = "python-cephclient"
8PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-v${PV}.tar.gz"
9
10SRC_URI[md5sum] = "e3746607f1af1573a241b4995c10c938"
11SRC_URI[sha256sum] = "9776b786da2aebdc0439ea2f809cc8923f52bc0cf610f77a9c1348466961134b"
12
13inherit setuptools pypi
14
15# DEPENDS_default: python-pip
16
17DEPENDS += " \
18 python-pip \
19 "
20
21# RDEPENDS_default:
22RDEPENDS_${PN} += " \
23 python-lxml \
24 python-requests \
25 python-cython \
26 "
diff --git a/meta-openstack/recipes-devtools/python/python3-cephclient_0.1.0.5.bb b/meta-openstack/recipes-devtools/python/python3-cephclient_0.1.0.5.bb
new file mode 100644
index 0000000..e05c1d5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cephclient_0.1.0.5.bb
@@ -0,0 +1,2 @@
1require python-cephclient.inc
2inherit setuptools3