summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-04 15:04:42 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-06 14:10:45 -0500
commit3b9f0cb0c2c241f0f99690e66586a654f7b23b39 (patch)
treed13c54823624136633e98b0052802bce659c7a25
parent5f0185d896e47beb09b6ceedde8820ddd147bd0a (diff)
downloadmeta-cloud-services-3b9f0cb0c2c241f0f99690e66586a654f7b23b39.tar.gz
python-pathlib: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pathlib.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb25
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb2
3 files changed, 27 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pathlib.inc b/meta-openstack/recipes-devtools/python/python-pathlib.inc
new file mode 100644
index 0000000..1df01f3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pathlib.inc
@@ -0,0 +1,23 @@
1SUMMARY = "Object-oriented filesystem paths"
2DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \
3It offers the following advantages over using string objects: \
4- No more cumbersome use of os and os.path functions. \
5- Embodies the semantics of different path types. \
6- Well-defined semantics, eliminating any warts or ambiguities. \
7"
8HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
9SECTION = "devel/python"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
12
13SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
14SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
15
16inherit pypi
17
18DEPENDS += " \
19 ${PYTHON_PN}-pip \
20"
21
22RDEPENDS_${PN} += " \
23"
diff --git a/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb b/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
index 21c02a2..02aafbf 100644
--- a/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
@@ -1,23 +1,2 @@
1SUMMARY = "Object-oriented filesystem paths" 1require python-pathlib.inc
2DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \ 2inherit setuptools
3It offers the following advantages over using string objects: \
4- No more cumbersome use of os and os.path functions. \
5- Embodies the semantics of different path types. \
6- Well-defined semantics, eliminating any warts or ambiguities. \
7"
8HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
9SECTION = "devel/python"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
12
13SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
14SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
15
16inherit setuptools pypi
17
18DEPENDS += " \
19 python-pip \
20"
21
22RDEPENDS_${PN} += " \
23"
diff --git a/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
new file mode 100644
index 0000000..afed21e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pathlib_1.0.1.bb
@@ -0,0 +1,2 @@
1require python-pathlib.inc
2inherit setuptools3