summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2015-09-22 12:28:21 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-09-22 14:40:09 -0400
commit3aea9262da4dfd639a9b376da09dc968042e8f8c (patch)
tree50ec21f1baf3914e18252945a2b672ba4591975c
parent18e2886555209378a315da3a92319c2f7c096ef8 (diff)
downloadmeta-cloud-services-3aea9262da4dfd639a9b376da09dc968042e8f8c.tar.gz
python packages: add build dependency on python-pbr
Some packages fail to build because their dependency on python-pbr during built time is not properly stated in the recipe. Sometimes the build succeeds anyway because the python-pbr package has already been built previously. To avoid the occasional build failure, this patch adds a dependency on python-pbr to all those packages that declare it as a dependency in their setup.py file. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_1.13.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glancestore_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.concurrency_1.9.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.context_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.db_1.9.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.i18n_1.6.0.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.log_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.middleware_1.1.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.policy_0.4.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.7.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.vmware_1.19.0.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslotest_1.6.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycadf_0.9.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb9
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-tooz_0.15.0.bb2
24 files changed, 77 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_1.13.0.bb b/meta-openstack/recipes-devtools/python/python-cliff_1.13.0.bb
index d8ef0af..49d4186 100644
--- a/meta-openstack/recipes-devtools/python/python-cliff_1.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-cliff_1.13.0.bb
@@ -15,8 +15,13 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
15 15
16inherit setuptools 16inherit setuptools
17 17
18DEPENDS += "\
19 python-pbr \
20 "
21
18RDEPENDS_${PN} += "python-prettytable \ 22RDEPENDS_${PN} += "python-prettytable \
19 python-cmd2 \ 23 python-cmd2 \
24 python-pbr \
20 python-pyparsing" 25 python-pyparsing"
21 26
22CLEANBROKEN = "1" 27CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
index ae32037..d80c570 100644
--- a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
@@ -28,5 +28,6 @@ RDEPENDS_${PN} = " \
28 python-cinderclient \ 28 python-cinderclient \
29 python-oslo.config \ 29 python-oslo.config \
30 python-oslo.i18n \ 30 python-oslo.i18n \
31 python-pbr \
31 " 32 "
32 33
diff --git a/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb b/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
index 3d6756a..1915fc1 100644
--- a/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat-cfntools_1.2.8.bb
@@ -15,3 +15,11 @@ SRC_URI[sha256sum] = "de7d93338d3afb71cc4c53d713740316ead0af3a9c869b1231617347e9
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18
19DEPENDS += "\
20 python-pbr \
21 "
22
23RDPENDS_${PN} += "\
24 python-pbr \
25 "
diff --git a/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb b/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
index 35131a7..5ae891b 100644
--- a/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
@@ -14,3 +14,11 @@ SRC_URI[sha256sum] = "9e42252f17d1dd89ee31745e0c4fbe58862c25147eb0ef5295c9cd9bcb
14S = "${WORKDIR}/${SRCNAME}-${PV}" 14S = "${WORKDIR}/${SRCNAME}-${PV}"
15 15
16inherit distutils 16inherit distutils
17
18DEPENDS += "\
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += "\
23 python-pbr \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb b/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
index 7ef5276..6d58573 100644
--- a/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
@@ -16,6 +16,10 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19DEPENDS += "\
20 python-pbr \
21 "
22
19RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
20 python-pbr \ 24 python-pbr \
21 python-fixtures \ 25 python-fixtures \
diff --git a/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb b/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
index 3fd26d3..3aa733e 100644
--- a/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
@@ -14,3 +14,11 @@ SRC_URI[sha256sum] = "875b54ac95e29cc83ae76513b48306c8493c12d5ba7d23aea3432216f2
14S = "${WORKDIR}/${SRCNAME}-${PV}" 14S = "${WORKDIR}/${SRCNAME}-${PV}"
15 15
16inherit setuptools 16inherit setuptools
17
18DEPENDS += "\
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += "\
23 python-pbr \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.concurrency_1.9.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.concurrency_1.9.0.bb
index 76d3424..c82f6ba 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.concurrency_1.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.concurrency_1.9.0.bb
@@ -19,8 +19,10 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-pbr \
26 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
index 05034f9..ec2651e 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
@@ -18,9 +18,11 @@ inherit setuptools
18DEPENDS += " \ 18DEPENDS += " \
19 python-pip \ 19 python-pip \
20 python-babel \ 20 python-babel \
21 python-pbr \
21 " 22 "
22 23
23# RDEPENDS_default: 24# RDEPENDS_default:
24RDEPENDS_${PN} += " \ 25RDEPENDS_${PN} += " \
25 bash \ 26 bash \
27 python-pbr \
26 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.db_1.9.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.db_1.9.0.bb
index 9ca1742..30f98f5 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.db_1.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.db_1.9.0.bb
@@ -17,6 +17,7 @@ inherit setuptools
17 17
18DEPENDS += " \ 18DEPENDS += " \
19 python-pip \ 19 python-pip \
20 python-pbr \
20 " 21 "
21 22
22RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
@@ -28,4 +29,5 @@ RDEPENDS_${PN} += " \
28 python-sqlalchemy \ 29 python-sqlalchemy \
29 python-sqlalchemy-migrate \ 30 python-sqlalchemy-migrate \
30 python-stevedore \ 31 python-stevedore \
32 python-pbr \
31 " 33 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.i18n_1.6.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.i18n_1.6.0.bb
index 575a8e5..2b47833 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.i18n_1.6.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.i18n_1.6.0.bb
@@ -25,4 +25,5 @@ DEPENDS += " \
25# RDEPENDS_default: 25# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-babel \ 27 python-babel \
28 python-pbr \
28 " 29 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
index 974578b..bfcbe31 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
@@ -18,6 +18,7 @@ inherit setuptools
18DEPENDS += " \ 18DEPENDS += " \
19 python-pip \ 19 python-pip \
20 python-babel \ 20 python-babel \
21 python-pbr \
21 " 22 "
22 23
23# RDEPENDS_default: 24# RDEPENDS_default:
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
index 8bb85cb..8841ec0 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
@@ -19,9 +19,11 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
26 bash \ 27 bash \
28 python-pbr \
27 " 29 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.middleware_1.1.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.middleware_1.1.0.bb
index b368eca..5c891f3 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.middleware_1.1.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.middleware_1.1.0.bb
@@ -19,8 +19,10 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-pbr \
26 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.policy_0.4.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.policy_0.4.0.bb
index 2816559..bfd6953 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.policy_0.4.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.policy_0.4.0.bb
@@ -18,10 +18,12 @@ inherit setuptools
18 18
19DEPENDS += " \ 19DEPENDS += " \
20 python-pip \ 20 python-pip \
21 python-pbr \
21" 22"
22 23
23RDEPENDS_${PN} += " \ 24RDEPENDS_${PN} += " \
24 python-oslo.config \ 25 python-oslo.config \
25 python-oslo.i18n \ 26 python-oslo.i18n \
26 python-oslo.serialization \ 27 python-oslo.serialization \
28 python-pbr \
27" 29"
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.7.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.7.0.bb
index d087a38..d391ed3 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.7.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.7.0.bb
@@ -19,8 +19,10 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-pbr \
26 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
index 7f0fb9c..db2869c 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
@@ -24,4 +24,5 @@ DEPENDS += " \
24 24
25# RDEPENDS_default: 25# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-pbr \
27 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
index 27a80b6..33c7e53 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
@@ -19,8 +19,10 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-pbr \
26 " 28 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.vmware_1.19.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.vmware_1.19.0.bb
index ace65ba..f39ff57 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.vmware_1.19.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.vmware_1.19.0.bb
@@ -21,4 +21,5 @@ DEPENDS += " \
21 " 21 "
22 22
23RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
24 python-pbr \
24 " 25 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslotest_1.6.0.bb b/meta-openstack/recipes-devtools/python/python-oslotest_1.6.0.bb
index 30cff23..6f4f766 100644
--- a/meta-openstack/recipes-devtools/python/python-oslotest_1.6.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslotest_1.6.0.bb
@@ -18,6 +18,10 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
18 18
19inherit setuptools 19inherit setuptools
20 20
21DEPENDS += "\
22 python-pbr \
23 "
24
21RDEPENDS_${PN} = "python-fixtures \ 25RDEPENDS_${PN} = "python-fixtures \
22 python-subunit \ 26 python-subunit \
23 python-testrepository \ 27 python-testrepository \
@@ -25,5 +29,6 @@ RDEPENDS_${PN} = "python-fixtures \
25 python-testtools \ 29 python-testtools \
26 python-mock \ 30 python-mock \
27 python-mox \ 31 python-mox \
32 python-pbr \
28 bash \ 33 bash \
29" 34"
diff --git a/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb b/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb
index 7e1fc09..1883dbb 100644
--- a/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb
@@ -20,10 +20,12 @@ inherit setuptools
20 20
21DEPENDS += " \ 21DEPENDS += " \
22 python-pip \ 22 python-pip \
23 python-pbr \
23 " 24 "
24 25
25# RDEPENDS_default: 26# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 27RDEPENDS_${PN} += " \
27 python-six \ 28 python-six \
28 python-webob \ 29 python-webob \
30 python-pbr \
29 " 31 "
diff --git a/meta-openstack/recipes-devtools/python/python-pycadf_0.9.0.bb b/meta-openstack/recipes-devtools/python/python-pycadf_0.9.0.bb
index a363119..afdc99b 100644
--- a/meta-openstack/recipes-devtools/python/python-pycadf_0.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-pycadf_0.9.0.bb
@@ -19,6 +19,7 @@ FILES_${PN} += "${datadir}/etc/${SRCNAME}/*"
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24RDEPENDS_${PN} += " \ 25RDEPENDS_${PN} += " \
@@ -29,4 +30,5 @@ RDEPENDS_${PN} += " \
29 python-pytz \ 30 python-pytz \
30 python-six \ 31 python-six \
31 python-webob \ 32 python-webob \
33 python-pbr \
32 " 34 "
diff --git a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
index 34c241b..994b6b5 100644
--- a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
@@ -16,4 +16,11 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19RDEPENDS_${PN} += " python-testtools" 19DEPENDS += "\
20 python-pbr \
21 "
22
23RDEPENDS_${PN} += "\
24 python-testtools \
25 python-pbr \
26 "
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb b/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
index a58c91a..fe03a5f 100644
--- a/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
@@ -21,4 +21,7 @@ DEPENDS += " \
21 python-pbr \ 21 python-pbr \
22" 22"
23 23
24RDEPENDS_${PN} += "python-extras" 24RDEPENDS_${PN} += "\
25 python-extras \
26 python-pbr \
27 "
diff --git a/meta-openstack/recipes-devtools/python/python-tooz_0.15.0.bb b/meta-openstack/recipes-devtools/python/python-tooz_0.15.0.bb
index dd4ed52..75e921e 100644
--- a/meta-openstack/recipes-devtools/python/python-tooz_0.15.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-tooz_0.15.0.bb
@@ -19,6 +19,7 @@ inherit setuptools
19 19
20DEPENDS += " \ 20DEPENDS += " \
21 python-pip \ 21 python-pip \
22 python-pbr \
22 " 23 "
23 24
24# RDEPENDS_default: 25# RDEPENDS_default:
@@ -27,4 +28,5 @@ RDEPENDS_${PN} += " \
27 python-zake \ 28 python-zake \
28 python-sysv-ipc \ 29 python-sysv-ipc \
29 python-memcache \ 30 python-memcache \
31 python-pbr \
30 " 32 "