summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-30 20:03:25 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-30 20:03:25 -0400
commit388b9c450fc5d0298cf2a5c69de04b3849c3923f (patch)
tree3bba8677a404176456827f36c4e124e7ae9ea048
parent8907cd1b5e461425c8820cc1805c47cb305825fe (diff)
downloadmeta-cloud-services-388b9c450fc5d0298cf2a5c69de04b3849c3923f.tar.gz
cinder: introduce python-futures dependency
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-futures_2.1.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-futures_2.1.6.bb b/meta-openstack/recipes-devtools/python/python-futures_2.1.6.bb
new file mode 100644
index 0000000..9dca758
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-futures_2.1.6.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Backport of the concurrent.futures package from Python 3.2"
2HOMEPAGE = "http://code.google.com/p/pythonfutures"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dd6708d05936d3f6c4e20ed14c87b5e3"
6
7PR = "r0"
8
9SRCNAME = "futures"
10SRC_URI = "http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "cfab9ac3cd55d6c7ddd0546a9f22f453"
13SRC_URI[sha256sum] = "33f39102b631fa0a030b24c4341ba1f48558e435946d6735d47fe1f739d757c4"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "