summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-23 23:28:12 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-23 23:28:12 -0400
commit29f2754423d4329136b314824a2637a8b02aefe4 (patch)
treee35aa39e08791affb04d15319e2c80827f25b3dd
parent27094db4e7d75627672f2aa39d4b76b8832c4d7a (diff)
downloadmeta-cloud-services-29f2754423d4329136b314824a2637a8b02aefe4.tar.gz
wsgi: WSGI (PEP 333) Reference Library
barbican uses the standalone wsgi reference library. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb b/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb
new file mode 100644
index 0000000..e25dd1d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "WSGI (PEP 333) Reference Library"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/wsgiref"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=fe761dfec1d54629c6b9a3bbc7b1baf5"
6
7PR = "r0"
8
9SRCNAME = "wsgiref"
10SRC_URI = "http://pypi.python.org/packages/source/w/${SRCNAME}/${SRCNAME}-${PV}.zip"
11
12SRC_URI[md5sum] = "29b146e6ebd0f9fb119fe321f7bcf6cb"
13SRC_URI[sha256sum] = "c7e610c800957046c04c8014aab8cce8f0b9f0495c8cd349e57c1f7cabf40e79"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "