summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-06-19 15:15:45 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-23 15:54:54 -0400
commit12d1a1749933ce0bfe0fff8f4856e3eaa5003c68 (patch)
tree3546cc892ea5bde24fc822899d8bbfd54d123a19
parentf86486f9ccb99115333691586ed4e99f074edc23 (diff)
downloadmeta-cloud-services-12d1a1749933ce0bfe0fff8f4856e3eaa5003c68.tar.gz
add python-logutils 0.3.3 bb file
New version of python-pecan (e.g pecan 0.5.0) requires python logutils. Signed-off-by: Vu Tran <vu.tran@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb b/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb
new file mode 100644
index 0000000..5b72be1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-logutils_0.3.3.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Set of handlers for the Python standard library's logging package"
2HOMEPAGE = "https://pypi.python.org/pypi/logutils"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b3cbf3c3220969afbf461f4a6ac97c9"
6
7PR = "r0"
8SRCNAME = "logutils"
9
10SRC_URI = "https://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "07b2a31d3d48e4f748363d33c03639cd"
13SRC_URI[sha256sum] = "4042b8e57cbe3b01552b3c84191595ae6c36f1ab5aef7e3a6ce5c2f15c297c9c"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# avoid "error: option --single-version-externally-managed not recognized"
20DISTUTILS_INSTALL_ARGS = "--root=${D} \
21 --prefix=${prefix} \
22 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
23 --install-data=${datadir}"