summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-19 05:22:03 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:34:21 -0400
commit0526abaa46612750ef332dbecd31291dee27a6c7 (patch)
tree00a2d4eaddfab7f45756ebd659cd89ef50d1ee61
parent0ef08fccf74e0b99b27d1947084c96d5fc3d3883 (diff)
downloadmeta-cloud-services-0526abaa46612750ef332dbecd31291dee27a6c7.tar.gz
python3-hp3parclient: Change to python3
Refresh the following patch: fix_hp3parclient_memory_leak.patch Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python3-hp3parclient/fix_hp3parclient_memory_leak.patch (renamed from meta-openstack/recipes-devtools/python/python-hp3parclient/fix_hp3parclient_memory_leak.patch)8
-rw-r--r--meta-openstack/recipes-devtools/python/python3-hp3parclient_3.2.0.bb (renamed from meta-openstack/recipes-devtools/python/python-hp3parclient_3.2.0.bb)0
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-hp3parclient/fix_hp3parclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python3-hp3parclient/fix_hp3parclient_memory_leak.patch
index ac196fd..25aebc0 100644
--- a/meta-openstack/recipes-devtools/python/python-hp3parclient/fix_hp3parclient_memory_leak.patch
+++ b/meta-openstack/recipes-devtools/python/python3-hp3parclient/fix_hp3parclient_memory_leak.patch
@@ -4,7 +4,7 @@
4 4
5--- a/hp3parclient/http.py 5--- a/hp3parclient/http.py
6+++ b/hp3parclient/http.py 6+++ b/hp3parclient/http.py
7@@ -61,6 +61,7 @@ 7@@ -66,6 +66,7 @@
8 self.set_debug_flag(http_log_debug) 8 self.set_debug_flag(http_log_debug)
9 9
10 self.times = [] # [("item", starttime, endtime), ...] 10 self.times = [] # [("item", starttime, endtime), ...]
@@ -25,7 +25,7 @@
25 def _http_log_req(self, args, kwargs): 25 def _http_log_req(self, args, kwargs):
26 if not self.http_log_debug: 26 if not self.http_log_debug:
27 return 27 return
28@@ -205,6 +212,9 @@ 28@@ -208,6 +215,9 @@
29 resp, body = self.request(url, method, **kwargs) 29 resp, body = self.request(url, method, **kwargs)
30 self.times.append(("%s %s" % (method, url), 30 self.times.append(("%s %s" % (method, url),
31 start_time, time.time())) 31 start_time, time.time()))
@@ -33,5 +33,5 @@
33+ while len(self.times) > self.times_max_len: 33+ while len(self.times) > self.times_max_len:
34+ del self.times[0] 34+ del self.times[0]
35 return resp, body 35 return resp, body
36 36
37 37 def _do_reauth(self, url, method, ex, **kwargs):
diff --git a/meta-openstack/recipes-devtools/python/python-hp3parclient_3.2.0.bb b/meta-openstack/recipes-devtools/python/python3-hp3parclient_3.2.0.bb
index 269c73e..269c73e 100644
--- a/meta-openstack/recipes-devtools/python/python-hp3parclient_3.2.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-hp3parclient_3.2.0.bb