summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-02-24 12:16:11 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-02-24 12:16:11 -0500
commit0431c45c2e0d61479eca447551f1631476b469a9 (patch)
treee5ab6181a384777097f7429098b99bcc4cbd0925
parent806abca4a5f914e5e02cbd42f9ee967d493559a6 (diff)
downloadmeta-cloud-services-0431c45c2e0d61479eca447551f1631476b469a9.tar.gz
support-libs: fix clean issues
With recent changes to oe-core make clean is run during the configuration phase of python packages. For some packages, this causes breakage as 'make clean' is not supported. To keep the build going, we mark them as brokenclean to avoid the issue. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-dateutil_1.5.bbappend1
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_1.4.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-flask_0.10.1.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python-itsdangerous_0.23.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-jinja2_2.7.1.bb14
-rw-r--r--meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-testrepository_0.0.18.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-werkzeug_0.9.4.bb13
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb3
10 files changed, 47 insertions, 3 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-dateutil_1.5.bbappend b/meta-openstack/recipes-devtools/python/python-dateutil_1.5.bbappend
new file mode 100644
index 0000000..68409e5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-dateutil_1.5.bbappend
@@ -0,0 +1 @@
CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_1.4.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_1.4.bb
index 9794c57..7989468 100644
--- a/meta-openstack/recipes-devtools/python/python-django-compressor_1.4.bb
+++ b/meta-openstack/recipes-devtools/python/python-django-compressor_1.4.bb
@@ -19,3 +19,5 @@ inherit setuptools
19 19
20RDEPENDS_${PN} += "python-django-appconf \ 20RDEPENDS_${PN} += "python-django-appconf \
21 " 21 "
22
23CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-flask_0.10.1.bb b/meta-openstack/recipes-devtools/python/python-flask_0.10.1.bb
index e07c3a2..263e53d 100644
--- a/meta-openstack/recipes-devtools/python/python-flask_0.10.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-flask_0.10.1.bb
@@ -15,3 +15,6 @@ SRC_URI[sha256sum] = "4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4
15S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18
19CLEANBROKEN = "1"
20
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index bf7f959..47f6a7c 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -177,3 +177,6 @@ RDEPENDS_${SRCNAME}-apache = "\
177 177
178MONITOR_SERVICE_PACKAGES = "${SRCNAME}" 178MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
179MONITOR_SERVICE_${SRCNAME} = "horizon" 179MONITOR_SERVICE_${SRCNAME} = "horizon"
180
181CLEANBROKEN = "1"
182
diff --git a/meta-openstack/recipes-devtools/python/python-itsdangerous_0.23.bb b/meta-openstack/recipes-devtools/python/python-itsdangerous_0.23.bb
index 8dbe48f..baeb549 100644
--- a/meta-openstack/recipes-devtools/python/python-itsdangerous_0.23.bb
+++ b/meta-openstack/recipes-devtools/python/python-itsdangerous_0.23.bb
@@ -18,3 +18,5 @@ inherit setuptools
18 18
19RDEPENDS_${PN} += "python-json python-netclient python-zlib python-datetime python-lang python-crypt" 19RDEPENDS_${PN} += "python-json python-netclient python-zlib python-datetime python-lang python-crypt"
20 20
21CLEANBROKEN = "1"
22
diff --git a/meta-openstack/recipes-devtools/python/python-jinja2_2.7.1.bb b/meta-openstack/recipes-devtools/python/python-jinja2_2.7.1.bb
index 878ca22..496d65a 100644
--- a/meta-openstack/recipes-devtools/python/python-jinja2_2.7.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-jinja2_2.7.1.bb
@@ -16,4 +16,16 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19RDEPENDS_${PN} += "python-io python-pickle python-crypt python-math python-netclient python-re python-textutils python-lang python-pprint python-shell python-markupsafe" 19RDEPENDS_${PN} += "python-io \
20 python-pickle \
21 python-crypt \
22 python-math \
23 python-netclient \
24 python-re \
25 python-textutils \
26 python-lang \
27 python-pprint \
28 python-shell \
29 python-markupsafe"
30
31CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb b/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
index b60322f..d52fe05 100644
--- a/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
@@ -21,8 +21,12 @@ inherit setuptools
21DEPENDS += " \ 21DEPENDS += " \
22 python-pip \ 22 python-pip \
23 libpcre \ 23 libpcre \
24 python-six \
24 " 25 "
25 26
26# RDEPENDS_default: 27# RDEPENDS_default:
27RDEPENDS_${PN} += " \ 28RDEPENDS_${PN} += " \
28 " 29 "
30
31CLEANBROKEN = "1"
32
diff --git a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.18.bb b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.18.bb
index 55270ba..f4e708e 100644
--- a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.18.bb
+++ b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.18.bb
@@ -19,4 +19,7 @@ inherit setuptools
19 19
20RDEPENDS_${PN} += "python-subunit \ 20RDEPENDS_${PN} += "python-subunit \
21 python-extras \ 21 python-extras \
22" \ No newline at end of file 22"
23
24CLEANBROKEN = "1"
25
diff --git a/meta-openstack/recipes-devtools/python/python-werkzeug_0.9.4.bb b/meta-openstack/recipes-devtools/python/python-werkzeug_0.9.4.bb
index 2d160b9..38e9f0f 100644
--- a/meta-openstack/recipes-devtools/python/python-werkzeug_0.9.4.bb
+++ b/meta-openstack/recipes-devtools/python/python-werkzeug_0.9.4.bb
@@ -16,5 +16,16 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
16 16
17inherit setuptools 17inherit setuptools
18 18
19RDEPENDS_${PN} += "python-io python-datetime python-email python-zlib python-pkgutil python-html python-shell python-pprint python-subprocess python-netserver" 19RDEPENDS_${PN} += "python-io \
20 python-datetime \
21 python-email \
22 python-zlib \
23 python-pkgutil \
24 python-html \
25 python-shell \
26 python-pprint \
27 python-subprocess \
28 python-netserver"
29
30CLEANBROKEN = "1"
20 31
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index 7de85e8..b03ca3e 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -29,3 +29,6 @@ DEPENDS += " \
29# RDEPENDS_default: 29# RDEPENDS_default:
30RDEPENDS_${PN} += " \ 30RDEPENDS_${PN} += " \
31 " 31 "
32
33CLEANBROKEN = "1"
34