summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarpat Mali <narpat.mali@windriver.com>2023-11-06 14:51:06 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-11-07 01:45:35 +0000
commit783826eceb1b09496099f00a008062c0f9f4ee4e (patch)
tree6db781ed3822def02cd89d821a339ff5251343ba
parent9d53be339b792fec2d05e17343d7b15d4331b6ca (diff)
downloadmeta-cloud-services-kirkstone.tar.gz
python3-ansible: Add locale-base-en-us to RDEPENDSkirkstone
Fixes: # export LANG='en_US.UTF-8' # ansible --version ERROR: Ansible requires the locale encoding to be UTF-8; Detected None. # python3 Python 3.10.9 (main, Dec 6 2022, 18:44:57) [GCC 11.3.0] on linux Type "help", "copyright", "credits" or "license" for more information. >>> import locale >>> locale.setlocale(locale.LC_CTYPE, ("en_US", "UTF-8")) Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.10/locale.py", line 620, in setlocale return _setlocale(category, locale) locale.Error: unsupported locale setting >>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Upstream master commit: https://git.yoctoproject.org/meta-cloud-services/commit/?id=cd048e11c4600636714051c787264a52be19c3f8 Signed-off-by: Narpat Mali <narpat.mali@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-ansible_2.14.11.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/python/python3-ansible_2.14.11.bb b/recipes-devtools/python/python3-ansible_2.14.11.bb
index ea0fdbe..f3ab237 100644
--- a/recipes-devtools/python/python3-ansible_2.14.11.bb
+++ b/recipes-devtools/python/python3-ansible_2.14.11.bb
@@ -1,7 +1,11 @@
1inherit setuptools3 1inherit setuptools3
2require python-ansible.inc 2require python-ansible.inc
3 3
4RDEPENDS:${PN} += "python3-pyyaml python3-jinja2 python3-modules" 4RDEPENDS:${PN} += "python3-pyyaml \
5 python3-jinja2 \
6 python3-modules \
7 locale-base-en-us \
8"
5 9
6SRC_URI += " \ 10SRC_URI += " \
7 file://python3-ensure-py-scripts-use-py3-for-shebang.patch \ 11 file://python3-ensure-py-scripts-use-py3-for-shebang.patch \