summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch')
-rw-r--r--recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch b/recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch
index e0d5790..d89f108 100644
--- a/recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch
+++ b/recipes-devtools/clang/clang/0032-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch
@@ -1,4 +1,4 @@
1From a333802272d875cc580b4f67e28205dfb0d40d3f Mon Sep 17 00:00:00 2001 1From ab07bcf103432f49aeff486e2898110c879e8bc0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 12 Aug 2022 11:50:57 -0700 3Date: Fri, 12 Aug 2022 11:50:57 -0700
4Subject: [PATCH] llvm: Do not use cmake infra to detect libzstd 4Subject: [PATCH] llvm: Do not use cmake infra to detect libzstd
@@ -21,7 +21,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
21 1 file changed, 4 insertions(+), 4 deletions(-) 21 1 file changed, 4 insertions(+), 4 deletions(-)
22 22
23diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt 23diff --git a/llvm/lib/Support/CMakeLists.txt b/llvm/lib/Support/CMakeLists.txt
24index 4cbc3b79f3bb..08c4bfd5efc1 100644 24index 8fbb2ca4c164..a6daa7c9f20f 100644
25--- a/llvm/lib/Support/CMakeLists.txt 25--- a/llvm/lib/Support/CMakeLists.txt
26+++ b/llvm/lib/Support/CMakeLists.txt 26+++ b/llvm/lib/Support/CMakeLists.txt
27@@ -22,7 +22,7 @@ if (HAS_WERROR_GLOBAL_CTORS) 27@@ -22,7 +22,7 @@ if (HAS_WERROR_GLOBAL_CTORS)
@@ -42,7 +42,7 @@ index 4cbc3b79f3bb..08c4bfd5efc1 100644
42 endif() 42 endif()
43 43
44 if( MSVC OR MINGW ) 44 if( MSVC OR MINGW )
45@@ -292,7 +292,7 @@ if(LLVM_ENABLE_ZLIB) 45@@ -291,7 +291,7 @@ if(LLVM_ENABLE_ZLIB)
46 get_property(zlib_library TARGET ZLIB::ZLIB PROPERTY LOCATION) 46 get_property(zlib_library TARGET ZLIB::ZLIB PROPERTY LOCATION)
47 endif() 47 endif()
48 get_library_name(${zlib_library} zlib_library) 48 get_library_name(${zlib_library} zlib_library)
@@ -51,7 +51,7 @@ index 4cbc3b79f3bb..08c4bfd5efc1 100644
51 endif() 51 endif()
52 52
53 if(LLVM_ENABLE_ZSTD) 53 if(LLVM_ENABLE_ZSTD)
54@@ -305,7 +305,7 @@ if(LLVM_ENABLE_ZSTD) 54@@ -304,7 +304,7 @@ if(LLVM_ENABLE_ZSTD)
55 get_property(zstd_library TARGET ${zstd_target} PROPERTY LOCATION) 55 get_property(zstd_library TARGET ${zstd_target} PROPERTY LOCATION)
56 endif() 56 endif()
57 get_library_name(${zstd_library} zstd_library) 57 get_library_name(${zstd_library} zstd_library)