summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch')
-rw-r--r--recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch b/recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch
deleted file mode 100644
index 9316599..0000000
--- a/recipes-devtools/clang/clang/0028-Add-libgcc-to-link-step-for-libcxx.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 397bd558b83ce7ff3ea69c1c8fb6f36c624b9ca6 Mon Sep 17 00:00:00 2001
2From: Jeremy Puhlman <jpuhlman@mvista.com>
3Date: Thu, 16 Jan 2020 21:16:10 +0000
4Subject: [PATCH] Add libgcc to link step for libcxx
5
6This corrects "undefined reference to __divti3"
7
8Upstream-Status: Inappropriate [configuration]
9
10Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com>
11---
12 libcxx/src/CMakeLists.txt | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libcxx/src/CMakeLists.txt b/libcxx/src/CMakeLists.txt
16index 31cd24333a5..d8ae826d7f5 100644
17--- a/libcxx/src/CMakeLists.txt
18+++ b/libcxx/src/CMakeLists.txt
19@@ -234,7 +234,7 @@ if (LIBCXX_ENABLE_SHARED)
20 llvm_setup_rpath(cxx_shared)
21 endif()
22 cxx_link_system_libraries(cxx_shared)
23- target_link_libraries(cxx_shared PRIVATE ${LIBCXX_LIBRARIES})
24+ target_link_libraries(cxx_shared PRIVATE ${LIBCXX_LIBRARIES} "$$($$CC --print-libgcc-file-name)")
25 set_target_properties(cxx_shared
26 PROPERTIES
27 COMPILE_FLAGS "${LIBCXX_COMPILE_FLAGS}"
28--
292.13.3
30