summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch')
-rw-r--r--recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch b/recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch
new file mode 100644
index 0000000..da038e2
--- /dev/null
+++ b/recipes-devtools/clang/clang/0026-compiler-rt-Link-scudo-with-SANITIZER_CXX_ABI_LIBRAR.patch
@@ -0,0 +1,28 @@
1From 1caf16b9a0a6d195bc66da996d6bcd3f66eeff07 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 19 May 2021 21:49:18 -0700
4Subject: [PATCH] compiler-rt: Link scudo with SANITIZER_CXX_ABI_LIBRARIES
5
6If SANITIZER_CXX_ABI_LIBRARIES is set then link scudo with it, this
7fixes build time errors like
8
9projects/compiler-rt/lib/sanitizer_common/CMakeFiles/RTSanitizerCommonLibc.armhf.dir/sanitizer_posix_libcdep.cpp.o: in function `__sanitizer::UnsetAlternateSignalStack()':
10| sanitizer_posix_libcdep.cpp:(.text+0x3d2): undefined reference to `__cxa_guard_acquire'
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 compiler-rt/lib/scudo/CMakeLists.txt | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/compiler-rt/lib/scudo/CMakeLists.txt b/compiler-rt/lib/scudo/CMakeLists.txt
18index 995e853e2a4d..25b79a8d17e8 100644
19--- a/compiler-rt/lib/scudo/CMakeLists.txt
20+++ b/compiler-rt/lib/scudo/CMakeLists.txt
21@@ -15,6 +15,7 @@ append_list_if(COMPILER_RT_HAS_LIBDL dl SCUDO_MINIMAL_DYNAMIC_LIBS)
22 append_list_if(COMPILER_RT_HAS_LIBRT rt SCUDO_MINIMAL_DYNAMIC_LIBS)
23 append_list_if(COMPILER_RT_HAS_LIBPTHREAD pthread SCUDO_MINIMAL_DYNAMIC_LIBS)
24 append_list_if(COMPILER_RT_HAS_LIBLOG log SCUDO_MINIMAL_DYNAMIC_LIBS)
25+append_list_if(SANITIZER_CXX_ABI_LIBRARIES ${SANITIZER_CXX_ABI_LIBRARIES} SCUDO_MINIMAL_DYNAMIC_LIBS)
26 append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer
27 SCUDO_CFLAGS)
28