summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch')
-rw-r--r--recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch b/recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch
new file mode 100644
index 0000000..2890228
--- /dev/null
+++ b/recipes-devtools/clang/clang/0024-fix-path-to-libffi.patch
@@ -0,0 +1,28 @@
1From 52b4e74809eba796663f0f65194ab4f3eafe2cb1 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Fri, 3 Apr 2020 15:10:37 +0800
4Subject: [PATCH] fix path to libffi
5
6FFI_LIBRARY_PATH is the full path to libffi so when building something that links to
7libLLVMInterpreter, we were looking for libffi in clang's recipe-sysroot instead of
8the recipe's sysroot.
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt b/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
16index b8adea5..7d8434c 100644
17--- a/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
18+++ b/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
19@@ -16,5 +16,5 @@ add_llvm_component_library(LLVMInterpreter
20 )
21
22 if( LLVM_ENABLE_FFI )
23- target_link_libraries( LLVMInterpreter PRIVATE ${FFI_LIBRARY_PATH} )
24+ target_link_libraries( LLVMInterpreter PRIVATE ffi )
25 endif()
26--
272.7.4
28