summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch')
-rw-r--r--recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch b/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
index 310e8d0..6189ae8 100644
--- a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
+++ b/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
@@ -1,4 +1,4 @@
1From c82435d462420d64e4fd249bd6673a12ef38d433 Mon Sep 17 00:00:00 2001 1From d9a483714b1ca13903024e4256b0b1beb5a1e2f6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 18 Jul 2016 08:05:02 +0000 3Date: Mon, 18 Jul 2016 08:05:02 +0000
4Subject: [PATCH] compiler-rt: Disable tsan on OE/glibc 4Subject: [PATCH] compiler-rt: Disable tsan on OE/glibc
@@ -13,10 +13,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
13 2 files changed, 2 insertions(+), 2 deletions(-) 13 2 files changed, 2 insertions(+), 2 deletions(-)
14 14
15diff --git a/compiler-rt/cmake/config-ix.cmake b/compiler-rt/cmake/config-ix.cmake 15diff --git a/compiler-rt/cmake/config-ix.cmake b/compiler-rt/cmake/config-ix.cmake
16index 3cc4c22304e..9da891b62e9 100644 16index 3aad08e8896..a979d38c7a6 100644
17--- a/compiler-rt/cmake/config-ix.cmake 17--- a/compiler-rt/cmake/config-ix.cmake
18+++ b/compiler-rt/cmake/config-ix.cmake 18+++ b/compiler-rt/cmake/config-ix.cmake
19@@ -619,7 +619,7 @@ else() 19@@ -653,7 +653,7 @@ else()
20 endif() 20 endif()
21 21
22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND 22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND
@@ -26,10 +26,10 @@ index 3cc4c22304e..9da891b62e9 100644
26 else() 26 else()
27 set(COMPILER_RT_HAS_TSAN FALSE) 27 set(COMPILER_RT_HAS_TSAN FALSE)
28diff --git a/compiler-rt/test/sanitizer_common/CMakeLists.txt b/compiler-rt/test/sanitizer_common/CMakeLists.txt 28diff --git a/compiler-rt/test/sanitizer_common/CMakeLists.txt b/compiler-rt/test/sanitizer_common/CMakeLists.txt
29index 48fccf05855..b4a7f0adf14 100644 29index fcd651ebe42..821de915be8 100644
30--- a/compiler-rt/test/sanitizer_common/CMakeLists.txt 30--- a/compiler-rt/test/sanitizer_common/CMakeLists.txt
31+++ b/compiler-rt/test/sanitizer_common/CMakeLists.txt 31+++ b/compiler-rt/test/sanitizer_common/CMakeLists.txt
32@@ -6,7 +6,7 @@ set(SANITIZER_COMMON_TESTSUITES) 32@@ -11,7 +11,7 @@ set(SANITIZER_COMMON_TESTSUITES)
33 # FIXME(dliew): We should switch to COMPILER_RT_SANITIZERS_TO_BUILD instead of 33 # FIXME(dliew): We should switch to COMPILER_RT_SANITIZERS_TO_BUILD instead of
34 # the hard coded `SUPPORTED_TOOLS_INIT` list once we know that the other 34 # the hard coded `SUPPORTED_TOOLS_INIT` list once we know that the other
35 # sanitizers work. 35 # sanitizers work.