summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/bcc/bcc_0.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/bcc/bcc_0.13.0.bb')
-rw-r--r--recipes-devtools/bcc/bcc_0.13.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/bcc/bcc_0.13.0.bb b/recipes-devtools/bcc/bcc_0.13.0.bb
new file mode 100644
index 0000000..2a346c1
--- /dev/null
+++ b/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6DEPENDS += "bison-native \
7 ninja-native \
8 elfutils-native \
9 flex-native \
10 ${MLPREFIX}elfutils \
11 ${MLPREFIX}binutils \
12 ${MLPREFIX}flex \
13 luajit \
14 clang \
15 "
16
17RDEPENDS_${PN} += "bash python3 python3-core"
18
19SRC_URI = "git://github.com/iovisor/bcc \
20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \
21 file://0001-BCC-Use-python-3.patch \
22 "
23SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
24
25S = "${WORKDIR}/git"
26
27inherit cmake
28
29EXTRA_OECMAKE = " \
30 -DCMAKE_INSTALL_PREFIX=/usr \
31 -DENABLE_LLVM_SHARED=ON \
32 -DENABLE_CLANG_JIT=ON \
33 -DENABLE_MAN=OFF \
34 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
35 -DPYTHON_CMD=python3 \
36"
37
38FILES_${PN} += "${libdir}/python*/dist-packages"
39
40COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"