summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch')
-rw-r--r--recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch b/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
new file mode 100644
index 0000000..b5acadc
--- /dev/null
+++ b/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
@@ -0,0 +1,32 @@
1From 93cf25ba663e68a6a6f4237fbe0ef8349b3f37ef Mon Sep 17 00:00:00 2001
2From: Sumit Garg <sumit.garg@linaro.org>
3Date: Fri, 14 Feb 2020 07:40:11 +0000
4Subject: [PATCH] Allow to build with OE LLVM cross compiled package
5
6The default LLVM cmake package requires all libraries, headers and tools
7to be present but in case of cross compilation, OE only provides
8target specific libraries and headers and requires native llvm tools.
9
10So instead of looking for a complete llvm package, look for libraries and
11headers which are installed in target sysroot-recipe path.
12
13Signed-off-by: Sumit Garg <sumit.garg@linaro.org>
14---
15 CMakeLists.txt | 2 --
16 1 file changed, 2 deletions(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 7bd0f3b2..6f1f12c0 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -39,8 +39,6 @@ endif()
23 if(NOT PYTHON_ONLY AND ENABLE_CLANG_JIT)
24 find_package(BISON)
25 find_package(FLEX)
26-find_package(LLVM REQUIRED CONFIG)
27-message(STATUS "Found LLVM: ${LLVM_INCLUDE_DIRS} ${LLVM_PACKAGE_VERSION}")
28 find_package(LibElf REQUIRED)
29
30 # clang is linked as a library, but the library path searching is
31--
322.17.1