summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch')
-rw-r--r--dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch b/dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch
new file mode 100644
index 0000000..7094cca
--- /dev/null
+++ b/dynamic-layers/selinux/android-tools/android-tools/libadb_mk_change_out_dir.patch
@@ -0,0 +1,44 @@
1libadb.mk: modifications to make it build in yocto environment
2
3Adding an include file that is setting the common flags.
4Changed the cppflag to include the headers from other components
5of android-tools
6
7Modified LDflags so that the libraries that are coming from other android-tools
8are searched in the output folder.
9
10Modified the build rule so that it outputs the binary to the OUT_DIR
11
12Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com>
13
14--- git/system/core/debian/libadb.mk 2021-04-30 16:29:34.596618862 +0200
15+++ git/system/core/debian/libadb.mk 2021-04-30 16:36:53.932837490 +0200
16@@ -1,3 +1,4 @@
17+include ../../rules_yocto.mk
18 NAME := libadb
19
20 LIBADB_SRC_FILES := \
21@@ -43,18 +44,18 @@
22 -Ibase/include \
23 -Idiagnose_usb/include \
24 -Ilibcrypto_utils/include \
25- -Iinclude \
26+ -Iinclude -I$(OUT_DIR)/usr/include \
27 -DPLATFORM_TOOLS_VERSION='"$(PLATFORM_TOOLS_VERSION)"' \
28 -DADB_HOST=1 -DADB_VERSION='"$(DEB_VERSION)"'
29
30 LDFLAGS += -shared -Wl,-soname,$(NAME).so.0 \
31 -Wl,-rpath=/usr/lib/$(DEB_HOST_MULTIARCH)/android \
32- -L/usr/lib/$(DEB_HOST_MULTIARCH)/android -lcrypto \
33- -lpthread -L. -lbase -lcutils -lcrypto_utils -lusb-1.0
34+ -L$(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android -lcrypto \
35+ -lpthread -lbase -lcutils -lcrypto_utils -lusb-1.0
36
37 $(NAME).so: $(SOURCES)
38- $(CXX) $^ -o $(NAME).so.0 $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS)
39- ln -s $(NAME).so.0 $(NAME).so
40+ $(CXX) $^ -o $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so.0 $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS)
41+ ln -s $(NAME).so.0 $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so
42
43 transport_mdns_unsupported.cpp:
44 echo 'void init_mdns_transport_discovery(void) {}' > transport_mdns_unsupported.cpp