summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
index 7e8ec73..556722c 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
@@ -13,15 +13,26 @@ DEPENDS += "bison-native \
13 libbpf \ 13 libbpf \
14 " 14 "
15 15
16DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest xxd-native', '', d)}"
16PV .= "+git${SRCREV}" 17PV .= "+git${SRCREV}"
17RDEPENDS:${PN} += "bash python3 xz" 18RDEPENDS:${PN} += "bash python3 xz"
19RDEPENDS:${PN}-ptest += "bash"
18 20
19SRC_URI = "git://github.com/iovisor/bpftrace;branch=master;protocol=https" 21SRC_URI = "git://github.com/iovisor/bpftrace;branch=master;protocol=https \
22 file://run-ptest \
23"
20SRCREV = "a277ec42102c463d656df8f64eb2f7e87e322210" 24SRCREV = "a277ec42102c463d656df8f64eb2f7e87e322210"
21 25
22S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
23 27
24inherit cmake 28inherit cmake ptest
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 install -m 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests
33 cp -rf ${B}/tests/runtime* ${D}${PTEST_PATH}/tests
34 cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests
35}
25 36
26def llvm_major_version(d): 37def llvm_major_version(d):
27 pvsplit = d.getVar('LLVMVERSION').split('.') 38 pvsplit = d.getVar('LLVMVERSION').split('.')
@@ -33,9 +44,9 @@ EXTRA_OECMAKE = " \
33 -DCMAKE_ENABLE_EXPORTS=1 \ 44 -DCMAKE_ENABLE_EXPORTS=1 \
34 -DCMAKE_BUILD_TYPE=Release \ 45 -DCMAKE_BUILD_TYPE=Release \
35 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \ 46 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \
36 -DBUILD_TESTING=OFF \
37 -DENABLE_MAN=OFF \ 47 -DENABLE_MAN=OFF \
38" 48"
49EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTING=ON', '-DBUILD_TESTING=OFF', d)}"
39 50
40COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" 51COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux"
41COMPATIBLE_HOST:libc-musl = "null" 52COMPATIBLE_HOST:libc-musl = "null"