summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
index 2272635..c881904 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace/0001-support-clang-upto-version-13.patch
@@ -1,9 +1,9 @@
1From 4cffb745dabde63f6f9c67a95265f5fc670dc1d7 Mon Sep 17 00:00:00 2001 1From 7b2f02a7b7d246b24cf029b3a75d8595b7b3c250 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 5 Aug 2021 22:15:27 -0700 3Date: Thu, 5 Aug 2021 22:15:27 -0700
4Subject: [PATCH] support clang upto version 13 4Subject: [PATCH 1/2] support clang upto version 13
5 5
6Upstream-Status: Pending 6Upstream-Status: Submitted [https://github.com/iovisor/bpftrace/pull/1962]
7Signed-off-by: Khem Raj <raj.khem@gmail.com> 7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8--- 8---
9 CMakeLists.txt | 2 +- 9 CMakeLists.txt | 2 +-
@@ -16,12 +16,11 @@ index 86daa195..73744207 100644
16@@ -162,7 +162,7 @@ else() 16@@ -162,7 +162,7 @@ else()
17 find_package(LLVM REQUIRED) 17 find_package(LLVM REQUIRED)
18 endif() 18 endif()
19 19
20- if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 12)) 20- if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 12))
21+ if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 13)) 21+ if((${LLVM_VERSION_MAJOR} VERSION_LESS 6) OR (${LLVM_VERSION_MAJOR} VERSION_GREATER 13))
22 message(SEND_ERROR "Unsupported LLVM version found: ${LLVM_INCLUDE_DIRS}") 22 message(SEND_ERROR "Unsupported LLVM version found: ${LLVM_INCLUDE_DIRS}")
23 message(SEND_ERROR "Specify an LLVM major version using LLVM_REQUESTED_VERSION=<major version>") 23 message(SEND_ERROR "Specify an LLVM major version using LLVM_REQUESTED_VERSION=<major version>")
24 endif() 24 endif()
25-- 25--
262.32.0 262.32.0
27