summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb
index 31ef5c2..cdacbb2 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.25.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5 5
6inherit cmake python3native manpages 6inherit cmake python3native manpages ptest
7 7
8DEPENDS += "bison-native \ 8DEPENDS += "bison-native \
9 flex-native \ 9 flex-native \
@@ -20,12 +20,15 @@ LUAJIT:powerpc64 = ""
20LUAJIT:riscv64 = "" 20LUAJIT:riscv64 = ""
21 21
22RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz" 22RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
23RDEPENDS:${PN}-ptest = "cmake python3 python3-distutils python3-netaddr python3-pyroute2"
23 24
24SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \ 25SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
25 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ 26 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
26 file://0001-tools-trace.py-Fix-failing-to-exit.patch \ 27 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
27 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \ 28 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
28 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \ 29 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \
30 file://run-ptest \
31 file://ptest_wrapper.sh \
29 " 32 "
30 33
31SRCREV = "711f03024d776d174874b1f833dac0597f22a49a" 34SRCREV = "711f03024d776d174874b1f833dac0597f22a49a"
@@ -54,6 +57,14 @@ do_install:append() {
54 -i $(find ${D}${datadir}/${PN} -type f) 57 -i $(find ${D}${datadir}/${PN} -type f)
55} 58}
56 59
60do_install_ptest() {
61 install -d ${D}${PTEST_PATH}/tests/cc
62 install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc
63 cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python
64 install ${WORKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests
65 install ${S}/examples/networking/simulation.py ${D}${PTEST_PATH}/tests/python
66}
67
57FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" 68FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
58FILES:${PN}-doc += "${datadir}/${PN}/man" 69FILES:${PN}-doc += "${datadir}/${PN}/man"
59 70