summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb
new file mode 100644
index 0000000..d6f70d3
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.17.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 elfutils \
11 luajit \
12 clang \
13 "
14
15RDEPENDS_${PN} += "bash python3 python3-core python3-setuptools xz"
16
17SRC_URI = "gitsm://github.com/iovisor/bcc \
18 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
19 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
20 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
21 "
22
23SRCREV = "ad5b82a5196b222ed2cdc738d8444e8c9546a77f"
24
25S = "${WORKDIR}/git"
26
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
29
30EXTRA_OECMAKE = " \
31 -DENABLE_LLVM_SHARED=ON \
32 -DENABLE_CLANG_JIT=ON \
33 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
34 -DPYTHON_CMD=${PYTHON} \
35 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
36"
37
38do_install_append() {
39 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
40 -i $(find ${D}${datadir}/${PN} -type f)
41}
42
43FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
44FILES_${PN}-doc += "${datadir}/${PN}/man"
45
46COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"