summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb
new file mode 100644
index 0000000..2df77ed
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.15.0.bb
@@ -0,0 +1,45 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 elfutils \
11 luajit \
12 clang \
13 "
14
15RDEPENDS_${PN} += "bash python3 python3-core python3-setuptools xz"
16
17SRC_URI = "gitsm://github.com/iovisor/bcc \
18 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
19 file://0001-tools-opensnoop-snoop-do_sys_openat2-for-kernel-v5.6.patch \
20 "
21
22SRCREV = "e41f7a3be5c8114ef6a0990e50c2fbabea0e928e"
23
24S = "${WORKDIR}/git"
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
28
29EXTRA_OECMAKE = " \
30 -DENABLE_LLVM_SHARED=ON \
31 -DENABLE_CLANG_JIT=ON \
32 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
33 -DPYTHON_CMD=${PYTHON} \
34 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
35"
36
37do_install_append() {
38 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
39 -i $(find ${D}${datadir}/${PN} -type f)
40}
41
42FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
43FILES_${PN}-doc += "${datadir}/${PN}/man"
44
45COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"