summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
index e9bc1a3..ec3811e 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
@@ -10,17 +10,11 @@ DEPENDS += "bison-native \
10 zip-native \ 10 zip-native \
11 flex \ 11 flex \
12 elfutils \ 12 elfutils \
13 ${LUAJIT} \
14 clang \ 13 clang \
15 libbpf \ 14 libbpf \
16 python3-setuptools-native \ 15 python3-setuptools-native \
17 " 16 "
18 17
19LUAJIT ?= "luajit"
20LUAJIT:powerpc64le = ""
21LUAJIT:powerpc64 = ""
22LUAJIT:riscv64 = ""
23
24RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz" 18RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
25RDEPENDS:${PN}-ptest = "cmake python3 python3-netaddr python3-pyroute2" 19RDEPENDS:${PN}-ptest = "cmake python3 python3-netaddr python3-pyroute2"
26 20
@@ -57,6 +51,7 @@ do_install:append() {
57 -i $(find ${D}${datadir}/${PN} -type f) 51 -i $(find ${D}${datadir}/${PN} -type f)
58 sed -e 's@#!/usr/bin/python.*@#!/usr/bin/env python3@g' \ 52 sed -e 's@#!/usr/bin/python.*@#!/usr/bin/env python3@g' \
59 -i $(find ${D}${datadir}/${PN} -type f) 53 -i $(find ${D}${datadir}/${PN} -type f)
54 rm -rf ${D}${datadir}/bcc/examples/lua
60} 55}
61 56
62do_install_ptest() { 57do_install_ptest() {