summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md8
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb6
-rw-r--r--recipes-devtools/clang/libcxx_git.bb3
3 files changed, 10 insertions, 7 deletions
diff --git a/README.md b/README.md
index 924f95f..2d7dc1a 100644
--- a/README.md
+++ b/README.md
@@ -45,14 +45,16 @@ Note that by default libstdc++ will remain the default C++ standard library, how
45libc++ to be the default one then set 45libc++ to be the default one then set
46 46
47```python 47```python
48TARGET_CXXFLAGS_append_toolchain-clang ?= " -stdlib=libc++ " 48CXX_append_toolchain-clang = " -stdlib=libc++ "
49TARGET_CXXFLAGS_append_toolchain-clang = " -stdlib=libc++ "
49``` 50```
50 51
51in local.conf. 52in local.conf.
52You can select libc++ per package too by writing bbappends for them containing 53You can select libc++ per package too by writing bbappends for them containing
53 54
54```python 55```python
55TARGET_CXXFLAGS_append_toolchain-clang = " -stdlib=libc++ " 56CXX_append_toolchain-clang_pn-<recipe> = " -stdlib=libc++ "
57TARGET_CXXFLAGS_append_toolchain-clang_pn-<recipe> = " -stdlib=libc++ "
56``` 58```
57 59
58# Building 60# Building
@@ -82,7 +84,7 @@ and OE will start using gcc to cross compile that recipe.
82And if a component does not build with libc++, you can add it to conf/nonclangable.inc e.g. 84And if a component does not build with libc++, you can add it to conf/nonclangable.inc e.g.
83 85
84```shell 86```shell
85TARGET_CXXFLAGS_remove_pn-<recipe>_toolchain-clang = " -stdlib=libc++ " 87CXX_remove_pn-<recipe>_toolchain-clang = " -stdlib=libc++ "
86``` 88```
87 89
88# Dependencies 90# Dependencies
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 68655e3..2cfbf71 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -15,9 +15,9 @@ inherit cmake pkgconfig pythonnative
15LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=f981c4637a4cd67915ac527b3ead3a59; \ 15LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=f981c4637a4cd67915ac527b3ead3a59; \
16" 16"
17 17
18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" 18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx"
19BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" 19CXX_remove_toolchain-clang = "-stdlib=libc++"
20TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 20TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++"
21TUNE_CCARGS_remove = "-no-integrated-as" 21TUNE_CCARGS_remove = "-no-integrated-as"
22DEPENDS += "ninja-native" 22DEPENDS += "ninja-native"
23DEPENDS_append_class-nativesdk = " clang-native" 23DEPENDS_append_class-nativesdk = " clang-native"
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index a90cd2f..28ea5eb 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -13,7 +13,8 @@ inherit cmake pythonnative
13 13
14DEPENDS += "ninja-native" 14DEPENDS += "ninja-native"
15BASEDEPENDS_remove_toolchain-clang = "libcxx" 15BASEDEPENDS_remove_toolchain-clang = "libcxx"
16TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 16CXX_remove_toolchain-clang = "-stdlib=libc++"
17TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++"
17 18
18PACKAGECONFIG ??= "unwind" 19PACKAGECONFIG ??= "unwind"
19PACKAGECONFIG_powerpc = "" 20PACKAGECONFIG_powerpc = ""