summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb b/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb
new file mode 100644
index 0000000..6f66549
--- /dev/null
+++ b/recipes-devtools/bindgen-cli/bindgen-cli_0.64.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Automatically generates Rust FFI bindings to C and C++ libraries."
2HOMEPAGE = "https://rust-lang.github.io/rust-bindgen/"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://bindgen-cli/LICENSE;md5=0b9a98cb3dcdefcceb145324693fda9b"
6
7inherit rust cargo cargo-update-recipe-crates
8
9SRC_URI = "git://github.com/rust-lang/rust-bindgen.git;protocol=https;nobranch=1;branch=main"
10SRCREV = "ae6817256ac557981906e93a1f866349db85053e"
11
12S = "${WORKDIR}/git"
13
14CARGO_SRC_DIR = "bindgen-cli"
15CARGO_LOCK_SRC_DIR = "bindgen-cli"
16
17do_install:append:class-native() {
18 create_wrapper ${D}/${bindir}/bindgen LIBCLANG_PATH="${STAGING_LIBDIR_NATIVE}"
19}
20
21RDEPENDS:${PN} = "libclang"
22
23BBCLASSEXTEND = "native"