summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa/clang13.patch15
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend2
2 files changed, 0 insertions, 17 deletions
diff --git a/recipes-graphics/mesa/mesa/clang13.patch b/recipes-graphics/mesa/mesa/clang13.patch
deleted file mode 100644
index 8387b34..0000000
--- a/recipes-graphics/mesa/mesa/clang13.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
2+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
3@@ -351,8 +351,12 @@ lp_build_create_jit_compiler_for_module(
4 */
5 TargetOptions options;
6 #if defined(PIPE_ARCH_X86)
7+#if LLVM_VERSION_MAJOR >= 13
8+ // do nothing
9+#else
10 options.StackAlignmentOverride = 4;
11 #endif
12+#endif
13
14 builder.setEngineKind(EngineKind::JIT)
15 .setErrorStr(&Error)
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 492d25e..74888ba 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI:append:toolchain-clang = " file://clang13.patch "
4
5LDFLAGS:append:toolchain-clang = " -latomic -lm" 3LDFLAGS:append:toolchain-clang = " -latomic -lm"
6DEPENDS:append:toolchain-clang = " libatomic-ops" 4DEPENDS:append:toolchain-clang = " libatomic-ops"
7 5