summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-23 11:33:21 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-23 22:00:02 -0700
commita5373e65e813fa95607d0a01bb34835ca12fdcc6 (patch)
treebcef80ce59678598ad8fa3903fb88a8d521c1fad
parent27d31ea0ee2c4960f3cb1fbd214e99925d80575a (diff)
downloadmeta-clang-a5373e65e813fa95607d0a01bb34835ca12fdcc6.tar.gz
mesa: Drop clang13.patch
It is fixed in 21.2.4 release of mesa already Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-graphics/mesa/mesa/clang13.patch15
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend2
2 files changed, 0 insertions, 17 deletions
diff --git a/recipes-graphics/mesa/mesa/clang13.patch b/recipes-graphics/mesa/mesa/clang13.patch
deleted file mode 100644
index 8387b34..0000000
--- a/recipes-graphics/mesa/mesa/clang13.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
2+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
3@@ -351,8 +351,12 @@ lp_build_create_jit_compiler_for_module(
4 */
5 TargetOptions options;
6 #if defined(PIPE_ARCH_X86)
7+#if LLVM_VERSION_MAJOR >= 13
8+ // do nothing
9+#else
10 options.StackAlignmentOverride = 4;
11 #endif
12+#endif
13
14 builder.setEngineKind(EngineKind::JIT)
15 .setErrorStr(&Error)
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 492d25e..74888ba 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI:append:toolchain-clang = " file://clang13.patch "
4
5LDFLAGS:append:toolchain-clang = " -latomic -lm" 3LDFLAGS:append:toolchain-clang = " -latomic -lm"
6DEPENDS:append:toolchain-clang = " libatomic-ops" 4DEPENDS:append:toolchain-clang = " libatomic-ops"
7 5