summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/musl/musl_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend
index 2301366..a6a1bf5 100644
--- a/recipes-core/musl/musl_%.bbappend
+++ b/recipes-core/musl/musl_%.bbappend
@@ -2,4 +2,11 @@ DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}"
2TOOLCHAIN_x86-x32 = "gcc" 2TOOLCHAIN_x86-x32 = "gcc"
3TOOLCHAIN_riscv64 = "gcc" 3TOOLCHAIN_riscv64 = "gcc"
4TOOLCHAIN_powerpc64 = "gcc" 4TOOLCHAIN_powerpc64 = "gcc"
5
5inherit lto 6inherit lto
7
8# workaround until https://bugs.llvm.org/show_bug.cgi?id=44384
9# is fixed
10do_configure_prepend_toolchain-clang () {
11 sed -i -e '/frounding-math/d' ${S}/configure
12}