summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-26 19:36:34 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-21 08:25:54 -0800
commit8943cf0ed788cae381af8ce40b791de80d4c0940 (patch)
tree39b77f947dadf2f686795b950baa733a913ed21c
parent970cd853109f34a005e293fd7eda5f160d5889a3 (diff)
downloadmeta-clang-8943cf0ed788cae381af8ce40b791de80d4c0940.tar.gz
musl: Do not pass -frounding-math for now
clang/master hangs (can you believe) while compiling musl on armv7ve Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-core/musl/musl_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend
index 2301366..a6a1bf5 100644
--- a/recipes-core/musl/musl_%.bbappend
+++ b/recipes-core/musl/musl_%.bbappend
@@ -2,4 +2,11 @@ DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}"
2TOOLCHAIN_x86-x32 = "gcc" 2TOOLCHAIN_x86-x32 = "gcc"
3TOOLCHAIN_riscv64 = "gcc" 3TOOLCHAIN_riscv64 = "gcc"
4TOOLCHAIN_powerpc64 = "gcc" 4TOOLCHAIN_powerpc64 = "gcc"
5
5inherit lto 6inherit lto
7
8# workaround until https://bugs.llvm.org/show_bug.cgi?id=44384
9# is fixed
10do_configure_prepend_toolchain-clang () {
11 sed -i -e '/frounding-math/d' ${S}/configure
12}