summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
index 556722c..0c0ea2a 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.16.0.bb
@@ -13,7 +13,6 @@ DEPENDS += "bison-native \
13 libbpf \ 13 libbpf \
14 " 14 "
15 15
16DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest xxd-native', '', d)}"
17PV .= "+git${SRCREV}" 16PV .= "+git${SRCREV}"
18RDEPENDS:${PN} += "bash python3 xz" 17RDEPENDS:${PN} += "bash python3 xz"
19RDEPENDS:${PN}-ptest += "bash" 18RDEPENDS:${PN}-ptest += "bash"
@@ -27,11 +26,20 @@ S = "${WORKDIR}/git"
27 26
28inherit cmake ptest 27inherit cmake ptest
29 28
29PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
30
31# Clang-15.x crashes compiling some usdt tests
32# see https://github.com/llvm/llvm-project/issues/58477
33PACKAGECONFIG:remove:riscv64 = "tests"
34
35PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native"
36
30do_install_ptest() { 37do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests 38 if [ -e ${B}/tests/bpftrace_test ]; then
32 install -m 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests 39 install -Dm 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests/bpftrace_test
33 cp -rf ${B}/tests/runtime* ${D}${PTEST_PATH}/tests 40 cp -rf ${B}/tests/runtime* ${D}${PTEST_PATH}/tests
34 cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests 41 cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests
42 fi
35} 43}
36 44
37def llvm_major_version(d): 45def llvm_major_version(d):
@@ -46,7 +54,6 @@ EXTRA_OECMAKE = " \
46 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \ 54 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \
47 -DENABLE_MAN=OFF \ 55 -DENABLE_MAN=OFF \
48" 56"
49EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTING=ON', '-DBUILD_TESTING=OFF', d)}"
50 57
51COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" 58COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux"
52COMPATIBLE_HOST:libc-musl = "null" 59COMPATIBLE_HOST:libc-musl = "null"