summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorDmitry Baryshkov <dmitry.baryshkov@linaro.org>2023-02-15 05:46:50 +0300
committerKhem Raj <raj.khem@gmail.com>2023-02-15 08:30:20 -0800
commit59e053cee1ecbe0e2404ee107d8cbb362fa607c8 (patch)
treebc3bab0160b9e58c1c3b04b704f0abfb2d495ded /recipes-graphics
parent12eef7303b79a0473016ecd32851e13d3f44cc0b (diff)
downloadmeta-clang-59e053cee1ecbe0e2404ee107d8cbb362fa607c8.tar.gz
mesa: don't override PACKAGECONFIG[gallium-llvm] in non-clang case
Change mesa bbappend to override PACKAGECONFIG[gallium-llvm] only if clang toolchain is selected. Unfortunately this has to be implemented in a nasty way because there is no standard way to apply override to the variable flag setting. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 74888ba..17637b4 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -8,4 +8,6 @@ EXTRA_OEMASON:append:toolchain-clang:x86-64 = " -Dasm=false"
8 8
9export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config" 9export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config"
10 10
11PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils" 11CLANG_GALLIUM_LLVM = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils"
12
13PACKAGECONFIG[gallium-llvm] := "${@[d.getVarFlag('PACKAGECONFIG', 'gallium-llvm'), '${CLANG_GALLIUM_LLVM}'][d.getVar('TOOLCHAIN') == 'clang']}"