summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-07-17 11:14:10 -0700
committerKhem Raj <raj.khem@gmail.com>2021-07-18 10:19:35 -0700
commit314a7014e3abb9ef297aa293c2e56ad916c2dc84 (patch)
treeb40448fc319fa35f8c2082091f6a3aa35a373235 /recipes-graphics/mesa
parent5e3f7c2fd647ae9552a19f679f37260fc5ebecff (diff)
downloadmeta-clang-314a7014e3abb9ef297aa293c2e56ad916c2dc84.tar.gz
mesa: Use gcc on aarch64
clang master/13.x has started segfaulting while building mesa, until it is fixed upstream lets switch to using gcc for mesa Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index d382f40..b4410d2 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -11,3 +11,6 @@ EXTRA_OEMASON_append_toolchain-clang_x86-64 = " -Dasm=false"
11export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config" 11export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config"
12 12
13PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils" 13PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils"
14
15# see https://bugs.llvm.org/show_bug.cgi?id=51126
16TOOLCHAIN_aarch64 = "gcc"