summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-27 01:13:59 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-08 11:37:54 -0700
commit933795217f9142c246c359f92e8320516e5c66a5 (patch)
tree3a78f058f667bb8851e0f14171ce2b95e8d2fa77 /recipes-extended
parent55978074f349330367ffbbf991e3287141f8fe4d (diff)
downloadmeta-clang-933795217f9142c246c359f92e8320516e5c66a5.tar.gz
ghostscript: Fix build when using libc++
RUNTIME=llvm means we use libc++ instead of libstdc++ among other things Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ghostscript/ghostscript_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-extended/ghostscript/ghostscript_%.bbappend b/recipes-extended/ghostscript/ghostscript_%.bbappend
new file mode 100644
index 0000000..fe22e34
--- /dev/null
+++ b/recipes-extended/ghostscript/ghostscript_%.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3do_configure_prepend_toolchain-clang () {
4 if ${@bb.utils.contains('RUNTIME', 'llvm', 'true', 'false', d)}; then
5 sed -i -e "s|-stdlib=libstdc++|-stdlib=libc++|g" ${S}/configure.ac
6 fi
7}