summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-02-11 08:31:14 +0000
committerKhem Raj <raj.khem@gmail.com>2017-02-11 08:31:14 +0000
commit69ee819e00f5c879d6c95d294fa6ec88ab871005 (patch)
treecc02c2503fd7c4b787a5433ce37cc5567bf6becb /recipes-extended
parent67530841903f430bea31279cf40f54235d33d01d (diff)
downloadmeta-clang-69ee819e00f5c879d6c95d294fa6ec88ab871005.tar.gz
perf,mdadm: Fix build with clang
When clang is used to compile python then it needs to be there for building python extentions of perf Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/mdadm/mdadm_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-extended/mdadm/mdadm_%.bbappend b/recipes-extended/mdadm/mdadm_%.bbappend
new file mode 100644
index 0000000..903836e
--- /dev/null
+++ b/recipes-extended/mdadm/mdadm_%.bbappend
@@ -0,0 +1,6 @@
1# Fix errors like
2# | super-intel.c:1673:23: error: taking address of packed member 'size_high' of class or structure 'imsm_dev' may result in an unaligned pointer value [-Werror,-Waddress-of-packed-member]
3# | &dev->size_low, &dev->size_high);
4# | ^~~~~~~~~~~~~~
5
6CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member"