summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-01-09 12:12:15 +0000
committerKhem Raj <raj.khem@gmail.com>2023-01-09 09:52:36 -0800
commitb573f41170c4e3be8d5fc585bb8166218ed09d8b (patch)
tree3055b4e2467e6e9f4e76f2690395b804012a8e9c /recipes-devtools
parentab5fd425e72f5430a0d8306ecf19e3e89bb0cd74 (diff)
downloadmeta-clang-b573f41170c4e3be8d5fc585bb8166218ed09d8b.tar.gz
openmp: skip buildpaths QA check for openmp-staticdev
The /usr/lib/libomptarget.devicertl.a static library ends up with build paths embedded. The CMake files don't respect our CXXFLAGS so don't use the -fdebug-path-map arguments, but even adding those didn't solve it: it looks like code via goes via LLVM bytecode files doesn't get remapped? Until that is solved, skip the buildpath check. Signed-off-by: Ross Burton <ross.burton@arm.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/clang/openmp_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index 6087a93..4305232 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -44,6 +44,8 @@ FILES_SOLIBSDEV = ""
44FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}" 44FILES:${PN} += "${libdir}/lib*${SOLIBSDEV}"
45FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc" 45FILES:${PN}-libomptarget = "${libdir}/libomptarget-*.bc"
46INSANE_SKIP:${PN} = "dev-so" 46INSANE_SKIP:${PN} = "dev-so"
47# Currently the static libraries contain buildpaths
48INSANE_SKIP:${PN}-staticdev += "buildpaths"
47 49
48COMPATIBLE_HOST:mips64 = "null" 50COMPATIBLE_HOST:mips64 = "null"
49COMPATIBLE_HOST:riscv32 = "null" 51COMPATIBLE_HOST:riscv32 = "null"