summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorPhilip Lorenz <philip.lorenz@bmw.de>2024-02-12 12:08:08 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-14 13:28:14 -0800
commitaed185154328bc2df67cf34a592e358956d07df8 (patch)
tree3f10beb74d032e0cdb5e8c786b6549aeab15e015 /recipes-devtools
parent8e255e8e01e061b57677970a21877d6021fe6310 (diff)
downloadmeta-clang-aed185154328bc2df67cf34a592e358956d07df8.tar.gz
compiler-rt-sanitizers: Depend on compiler-rt
When configuring with COMPILER_RT_USE_BUILTINS_LIBRARY=ON, compiler-rt expects the target builtin libraries to be available. Make sure that this really is the case by adding them to DEPENDS. Without the dependency recipe build fails during the configure task | -- Failed to find compiler-rt builtins library for x86_64-poky-linux | CMake Error at .../build/tmp/work-shared/llvm-project-source-17.0.6-r0/git/compiler-rt/cmake/Modules/AddCompilerRT.cmake:281 (message): | Cannot find builtins library for the target architecture | Call Stack (most recent call first): | .../build/tmp/work-shared/llvm-project-source-17.0.6-r0/git/compiler-rt/lib/stats/CMakeLists.txt:23 (add_compiler_rt_runtime) Signed-off-by: Philip Lorenz <philip.lorenz@bmw.de>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/clang/compiler-rt-sanitizers_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
index 7a9b4ef..06c0e06 100644
--- a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
+++ b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee
15 15
16TUNE_CCARGS:remove = "-no-integrated-as" 16TUNE_CCARGS:remove = "-no-integrated-as"
17 17
18DEPENDS += "ninja-native virtual/crypt" 18DEPENDS += "ninja-native virtual/crypt compiler-rt"
19DEPENDS:append:class-native = " clang-native libxcrypt-native" 19DEPENDS:append:class-native = " clang-native libxcrypt-native"
20DEPENDS:append:class-nativesdk = " clang-native clang-crosssdk-${SDK_ARCH} nativesdk-libxcrypt" 20DEPENDS:append:class-nativesdk = " clang-native clang-crosssdk-${SDK_ARCH} nativesdk-libxcrypt"
21 21