diff options
author | zqz <z@qz.com> | 2023-05-10 16:32:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-10 20:58:09 -0700 |
commit | 33cacf181b776a8dcda1c5e7e908bf66b0690e02 (patch) | |
tree | 0220f49916e3f4fdc293c4cee3718bdd581005c9 /recipes-devtools | |
parent | a52e46d69a76ec8ab400cdae5409425eef4f5569 (diff) | |
download | meta-clang-33cacf181b776a8dcda1c5e7e908bf66b0690e02.tar.gz |
LLVM officially supports LoongArch starting from 16.0.0
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/clang/clang_git.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb index c9f05b9..15ba27c 100644 --- a/recipes-devtools/clang/clang_git.bb +++ b/recipes-devtools/clang/clang_git.bb | |||
@@ -41,6 +41,7 @@ def get_clang_arch(bb, d, arch_var): | |||
41 | elif re.match('riscv32$', a): return 'riscv32' | 41 | elif re.match('riscv32$', a): return 'riscv32' |
42 | elif re.match('riscv64$', a): return 'riscv64' | 42 | elif re.match('riscv64$', a): return 'riscv64' |
43 | elif re.match('p(pc|owerpc)(|64)', a): return 'PowerPC' | 43 | elif re.match('p(pc|owerpc)(|64)', a): return 'PowerPC' |
44 | elif re.match('loongarch64$', a): return 'loongarch64' | ||
44 | else: | 45 | else: |
45 | bb.note("'%s' is not a primary llvm architecture" % a) | 46 | bb.note("'%s' is not a primary llvm architecture" % a) |
46 | return "" | 47 | return "" |
@@ -104,7 +105,7 @@ LLVM_BUILD_TOOLS;LLVM_USE_HOST_TOOLS;LLVM_CONFIG_PATH;\ | |||
104 | # Gennerally setting LLVM_TARGETS_TO_BUILD = "" in local.conf is ok in most simple situations | 105 | # Gennerally setting LLVM_TARGETS_TO_BUILD = "" in local.conf is ok in most simple situations |
105 | # where only one target architecture is needed along with just one build arch (usually X86) | 106 | # where only one target architecture is needed along with just one build arch (usually X86) |
106 | # | 107 | # |
107 | LLVM_TARGETS_TO_BUILD ?= "AMDGPU;AArch64;ARM;BPF;Mips;PowerPC;RISCV;X86" | 108 | LLVM_TARGETS_TO_BUILD ?= "AMDGPU;AArch64;ARM;BPF;Mips;PowerPC;RISCV;X86;LoongArch" |
108 | 109 | ||
109 | LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ?= "" | 110 | LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ?= "" |
110 | LLVM_EXPERIMENTAL_TARGETS_TO_BUILD:append = ";${@get_clang_experimental_target_arch(bb, d)}" | 111 | LLVM_EXPERIMENTAL_TARGETS_TO_BUILD:append = ";${@get_clang_experimental_target_arch(bb, d)}" |