summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-13 11:45:21 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-14 00:47:23 -0700
commit2bbb0477e5578591daeba0d1bb9dcd500b31fdf3 (patch)
tree1239a9a98615a9aad9143f75328055cb235d7dd3 /recipes-devtools
parentf09586e588eb7784c83c3bd6bc028137b25df13d (diff)
downloadmeta-clang-2bbb0477e5578591daeba0d1bb9dcd500b31fdf3.tar.gz
clang: Define BINPATHPREFIX
This is to make stage2 as an optional step maybe a packageconfig Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/clang/clang_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index 4182921..1d9e4a0 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -139,6 +139,8 @@ DEPENDS_append_class-target = " clang-cross-${TARGET_ARCH} python3"
139 139
140BOOTSTRAPSTAGE ?= "" 140BOOTSTRAPSTAGE ?= ""
141BOOTSTRAPSTAGE_class-native = "stage2" 141BOOTSTRAPSTAGE_class-native = "stage2"
142BINPATHPREFIX ?= ""
143BINPATHPREFIX_class-native = "/tools/clang/stage2-bins/NATIVE"
142INSTALLTARGET ?= "install" 144INSTALLTARGET ?= "install"
143INSTALLTARGET_class-native = "stage2-install" 145INSTALLTARGET_class-native = "stage2-install"
144PASSTHROUGH ?= "" 146PASSTHROUGH ?= ""
@@ -168,8 +170,8 @@ do_install() {
168} 170}
169 171
170do_install_append_class-native () { 172do_install_append_class-native () {
171 install -Dm 0755 ${B}/tools/clang/stage2-bins/NATIVE/bin/clang-tblgen ${D}${bindir}/clang-tblgen 173 install -Dm 0755 ${B}${BINPATHPREFIX}/bin/clang-tblgen ${D}${bindir}/clang-tblgen
172 install -Dm 0755 ${B}/tools/clang/stage2-bins/NATIVE/bin/lldb-tblgen ${D}${bindir}/lldb-tblgen 174 install -Dm 0755 ${B}${BINPATHPREFIX}/bin/lldb-tblgen ${D}${bindir}/lldb-tblgen
173 for f in `find ${D}${bindir} -executable -type f -not -type l`; do 175 for f in `find ${D}${bindir} -executable -type f -not -type l`; do
174 test -n "`file $f|grep -i ELF`" && ${STRIP} $f 176 test -n "`file $f|grep -i ELF`" && ${STRIP} $f
175 echo "stripped $f" 177 echo "stripped $f"
@@ -177,8 +179,8 @@ do_install_append_class-native () {
177} 179}
178 180
179do_install_append_class-nativesdk () { 181do_install_append_class-nativesdk () {
180 install -Dm 0755 ${B}/bin/clang-tblgen ${D}${bindir}/clang-tblgen 182 install -Dm 0755 ${B}${BINPATHPREFIX}/bin/clang-tblgen ${D}${bindir}/clang-tblgen
181 install -Dm 0755 ${B}/bin/lldb-tblgen ${D}${bindir}/lldb-tblgen 183 install -Dm 0755 ${B}${BINPATHPREFIX}/bin/lldb-tblgen ${D}${bindir}/lldb-tblgen
182 for f in `find ${D}${bindir} -executable -type f -not -type l`; do 184 for f in `find ${D}${bindir} -executable -type f -not -type l`; do
183 test -n "`file $f|grep -i ELF`" && ${STRIP} $f 185 test -n "`file $f|grep -i ELF`" && ${STRIP} $f
184 done 186 done