summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNathan Trapp <nathan.trapp@savant.com>2015-07-03 13:08:53 -0400
committerKhem Raj <raj.khem@gmail.com>2015-07-08 00:21:54 -0700
commit07857ed923fc30c927e74306267bb4062fbed602 (patch)
tree97a13d559be7083658f2484c2f1ebd6bbac89948 /recipes-devtools
parentca4f08af1feb1b1826cf2f3f769fcb48b45d6ff8 (diff)
downloadmeta-clang-07857ed923fc30c927e74306267bb4062fbed602.tar.gz
clang: Fix nativesdk build
Signed-off-by: Nathan Trapp <nathan.trapp@savant.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/clang/clang_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index 52352f2..638096b 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -59,6 +59,8 @@ EXTRA_OECMAKE_append_class-native = "\
59" 59"
60EXTRA_OECMAKE_append_class-nativesdk = "\ 60EXTRA_OECMAKE_append_class-nativesdk = "\
61 -DLLVM_TARGETS_TO_BUILD:STRING='AArch64;ARM;Mips;PowerPC;X86' \ 61 -DLLVM_TARGETS_TO_BUILD:STRING='AArch64;ARM;Mips;PowerPC;X86' \
62 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
63 -DCLANG_TABLEGEN=${STAGING_BINDIR_NATIVE}/clang-tblgen \
62" 64"
63EXTRA_OECMAKE_append_class-target = "\ 65EXTRA_OECMAKE_append_class-target = "\
64 -DLLVM_ENABLE_PIC=False \ 66 -DLLVM_ENABLE_PIC=False \
@@ -75,6 +77,7 @@ EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
75 77
76DEPENDS = "zlib libffi libxml2 binutils" 78DEPENDS = "zlib libffi libxml2 binutils"
77DEPENDS_remove_class-nativesdk = "nativesdk-binutils" 79DEPENDS_remove_class-nativesdk = "nativesdk-binutils"
80DEPENDS_append_class-nativesdk = " clang-native "
78 81
79do_configure_prepend() { 82do_configure_prepend() {
80 # Remove RPATHs 83 # Remove RPATHs
@@ -98,8 +101,9 @@ do_install_append_class-native () {
98 test -n "`file $f|grep -i ELF`" && ${STRIP} $f 101 test -n "`file $f|grep -i ELF`" && ${STRIP} $f
99 done 102 done
100} 103}
104
101do_install_append_class-nativesdk () { 105do_install_append_class-nativesdk () {
102 install -Dm 0755 ${B}/NATIVE/bin/clang-tblgen ${D}${bindir}/clang-tblgen 106 install -Dm 0755 ${B}/bin/clang-tblgen ${D}${bindir}/clang-tblgen
103 for f in `find ${D}${bindir} -executable -type f -not -type l`; do 107 for f in `find ${D}${bindir} -executable -type f -not -type l`; do
104 test -n "`file $f|grep -i ELF`" && ${STRIP} $f 108 test -n "`file $f|grep -i ELF`" && ${STRIP} $f
105 done 109 done