summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorguillaume-pais-siemens <79512275+guillaume-pais-siemens@users.noreply.github.com>2021-10-05 07:53:45 +0200
committerKhem Raj <raj.khem@gmail.com>2021-12-15 13:14:39 -0800
commit0304ff4e533698a036b4df7307d0a2af29441414 (patch)
tree4862d966fa283488b2f6ec60f26e9b49010c829f /recipes-devtools
parent6967fccd0bda4508a98e341faaac5becdfdef3b7 (diff)
downloadmeta-clang-0304ff4e533698a036b4df7307d0a2af29441414.tar.gz
DEPENDS on virtual/${TARGET_PREFIX}binutils
```virtual/${TARGET_PREFIX}binutils``` shall be used and not ```binutils-cross-${TARGET_ARCH}``` In the case of an external arm toolchain, ```binutils-cross-aarch64``` does not exist and creates following error: ``` Missing or unbuildable dependency chain was: ['tisdk-base-image', 'packagegroup-core-standalone-sdk-target', 'libcxx-dev', 'compiler-rt', 'clang-cross-aarch64', 'binutils-cross-aarch64'] ``` Signed-off-by: Guillaume Pais <guillaume.pais@siemens.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/clang/clang-cross_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang-cross_git.bb b/recipes-devtools/clang/clang-cross_git.bb
index fd8ece5..abceb3d 100644
--- a/recipes-devtools/clang/clang-cross_git.bb
+++ b/recipes-devtools/clang/clang-cross_git.bb
@@ -11,7 +11,7 @@ PN = "clang-cross-${TARGET_ARCH}"
11require clang.inc 11require clang.inc
12require common-source.inc 12require common-source.inc
13inherit cross 13inherit cross
14DEPENDS += "clang-native binutils-cross-${TARGET_ARCH}" 14DEPENDS += "clang-native virtual/${TARGET_PREFIX}binutils"
15 15
16do_install() { 16do_install() {
17 install -d ${D}${bindir} 17 install -d ${D}${bindir}