summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-09-08 21:54:15 -0700
committerKhem Raj <raj.khem@gmail.com>2021-09-10 23:11:35 -0700
commit12c3739c9cc737ceb8a29bf7bbd848d3de4b8d17 (patch)
treefe4b74d42a2c809cfe1b5a86d3e93b2aff946672 /recipes-devtools/clang
parent3c131c2bac5ca105270a1ab075632f13cf8d8485 (diff)
downloadmeta-clang-12c3739c9cc737ceb8a29bf7bbd848d3de4b8d17.tar.gz
clang: Update to latest 13.x
Drop upstreamed patches Brings following changes * Workaround incorre ct types when lowering fixed length gather/scatter * f17d60d62028 Inform pass manager when child loops are deleted * f56129fe78d5 Fine grain control over some sym bol visibility * dc10ff25f54b [AArch64][SME] Fix imm bug in mov vector to tile aliases * b77c810feba0 Revert "[HardwareLoops] Change order of SCEV expression construction for Init LoopCount." * 02dece03f93d [clang] fix transformation of template arguments of 'auto' type constraints * 297e9237db53 [SelectionDAGBuilder] Bugfix in visitInlineAsm() * bc3cbd744d70 [llvm-objdump] Fix 'llvm-objdump -dr' for executables with relocations * 912ad5830cc1 Add llvm-ml to LLVM_TOOLCHAIN_TOOLS (PR50536) * b46abdb7b8fe [clang][Driver] Pick the last --driver-mode in case of multiple ones * 197d9d91aec1 [AArch64][sve] Prevent incorrect function call on fixed width vector * 427df19c4791 Update counter offset to account for binary ids * 09f659449b83 libunwind: add missing break statements in EHABI * a98b397504f8 [SCEV] Fix applyLoopGuards() with range check idiom (PR51760) * 9b3867e959fa [DAGCombine] Prevent the transform of combine for multi-use operand * 49dacda603b3 [tests] precommit tests for D107692 * 8aa8ed9d4b5f Fix for commit d8cd7806310c51af912a647a6ca46de62ff13214. * 2a1d8b5016eb [clang] OpenBSD does not support C11 atomics or threads. * a52b7bf7d123 PR50294: Fix a performance regression from 2c9dbcd. * c30b2813a1d5 [clang] fix error recovery ICE on copy elision when returing invalid variable * 6668e31250ba Support linking against OpenMP runtime on OpenBSD. * be305271bfb6 OpenBSD also needs execinfo * a5e968b66a59 [clang] Allow the OpenBSD driver to link the libclang_rt.profile library. * 181739213aa0 [docs] Update release notes with items related to Flang * c45fa58f171e [libomptarget][amdcgn] Only add opt/llvm-link dependency if TARGET is availab le * 7f3d00c9b49b [libomptarget][amdcgn] Add build dependency for llvm-link and opt * 3b1fa4aef006 [RISCV] Fix reporting of incorrect commutable operand indices * 1c3fcc8ae92e [libc++][NFC] Mark values in gdb pretty print comparison functions as live to prevent values being optimized out. * c8905f1bb304 [Orc] Enable debug object tests only on x86_64 hosts * 7a4a5d413624 [Linker] Support weak symbols in nodeduplicate COMDAT group Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang')
-rw-r--r--recipes-devtools/clang/clang.inc2
-rw-r--r--recipes-devtools/clang/clang/D108404.diff58
-rw-r--r--recipes-devtools/clang/clang/D108868.diff47
-rw-r--r--recipes-devtools/clang/common.inc2
4 files changed, 1 insertions, 108 deletions
diff --git a/recipes-devtools/clang/clang.inc b/recipes-devtools/clang/clang.inc
index 829c03b..37556b4 100644
--- a/recipes-devtools/clang/clang.inc
+++ b/recipes-devtools/clang/clang.inc
@@ -8,7 +8,7 @@ MAJOR_VER = "13"
8MINOR_VER = "0" 8MINOR_VER = "0"
9PATCH_VER = "0" 9PATCH_VER = "0"
10 10
11SRCREV ?= "9e41dc71b8d4040fa5f0742022d6cf9852096744" 11SRCREV ?= "0c2f8599a9cc42014b41aadf7c308b4889d2397f"
12 12
13PV = "${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}" 13PV = "${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}"
14BRANCH = "release/13.x" 14BRANCH = "release/13.x"
diff --git a/recipes-devtools/clang/clang/D108404.diff b/recipes-devtools/clang/clang/D108404.diff
deleted file mode 100644
index 68d8ebc..0000000
--- a/recipes-devtools/clang/clang/D108404.diff
+++ /dev/null
@@ -1,58 +0,0 @@
1Backported from https://reviews.llvm.org/D108404
2
3diff --git a/llvm/runtimes/CMakeLists.txt b/llvm/runtimes/CMakeLists.txt
4--- a/llvm/runtimes/CMakeLists.txt
5+++ b/llvm/runtimes/CMakeLists.txt
6@@ -350,15 +350,19 @@
7 # Create a runtimes target that uses this file as its top-level CMake file.
8 # The runtimes target is a configuration of all the runtime libraries
9 # together in a single CMake invocaiton.
10+ if("openmp" IN_LIST LLVM_ENABLE_RUNTIMES)
11+ message(STATUS "Adding dependencies opt llvm-link")
12+ set(extra_deps opt llvm-link)
13+ endif()
14 if(NOT LLVM_RUNTIME_TARGETS)
15 runtime_default_target(
16- DEPENDS ${deps}
17+ DEPENDS ${deps} ${extra_deps}
18 PREFIXES ${prefixes})
19 set(test_targets check-runtimes)
20 else()
21 if("default" IN_LIST LLVM_RUNTIME_TARGETS)
22 runtime_default_target(
23- DEPENDS ${deps}
24+ DEPENDS ${deps} ${extra_deps}
25 PREFIXES ${prefixes})
26 list(REMOVE_ITEM LLVM_RUNTIME_TARGETS "default")
27 else()
28diff --git a/openmp/libomptarget/DeviceRTL/CMakeLists.txt b/openmp/libomptarget/DeviceRTL/CMakeLists.txt
29--- a/openmp/libomptarget/DeviceRTL/CMakeLists.txt
30+++ b/openmp/libomptarget/DeviceRTL/CMakeLists.txt
31@@ -151,6 +151,7 @@
32
33 # Create target to build all Bitcode libraries.
34 add_custom_target(omptarget-new-nvptx-bc)
35+add_dependencies(omptarget-new-nvptx-bc opt llvm-link)
36
37 # Generate a Bitcode library for all the compute capabilities the user requested
38 foreach(sm ${nvptx_sm_list})
39@@ -197,6 +198,7 @@
40
41 add_custom_target(${bclib_target_name} ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${bclib_name}_opt)
42 add_dependencies(omptarget-new-nvptx-bc ${bclib_target_name})
43+ add_dependencies(${bclib_target_name} opt llvm-link)
44
45 # Copy library to destination.
46 add_custom_command(TARGET ${bclib_target_name} POST_BUILD
47diff --git a/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt b/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt
48--- a/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt
49+++ b/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt
50@@ -157,7 +157,7 @@
51 add_custom_command(
52 OUTPUT ${bc_libname}
53 COMMAND ${LINK_TOOL} ${bc_files} | ${OPT_TOOL} --always-inline -o ${OUTPUTDIR}/${bc_libname}
54- DEPENDS ${bc_files} opt)
55+ DEPENDS ${bc_files} llvm-link opt)
56
57 add_custom_target(lib${libname}-${mcpu} ALL DEPENDS ${bc_libname})
58
diff --git a/recipes-devtools/clang/clang/D108868.diff b/recipes-devtools/clang/clang/D108868.diff
deleted file mode 100644
index a12a3eb..0000000
--- a/recipes-devtools/clang/clang/D108868.diff
+++ /dev/null
@@ -1,47 +0,0 @@
1Backported from https://reviews.llvm.org/D108868
2
3--- a/llvm/runtimes/CMakeLists.txt
4+++ b/llvm/runtimes/CMakeLists.txt
5@@ -350,9 +350,14 @@ if(runtimes)
6 # Create a runtimes target that uses this file as its top-level CMake file.
7 # The runtimes target is a configuration of all the runtime libraries
8 # together in a single CMake invocaiton.
9+ set(extra_deps "")
10 if("openmp" IN_LIST LLVM_ENABLE_RUNTIMES)
11- message(STATUS "Adding dependencies opt llvm-link")
12- set(extra_deps opt llvm-link)
13+ if(TARGET opt)
14+ list(APPEND extra_deps opt)
15+ endif()
16+ if(TARGET llvm-link)
17+ list(APPEND extra_deps llvm-link)
18+ endif()
19 endif()
20 if(NOT LLVM_RUNTIME_TARGETS)
21 runtime_default_target(
22--- a/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt
23+++ b/openmp/libomptarget/deviceRTLs/amdgcn/CMakeLists.txt
24@@ -149,6 +149,14 @@ endmacro()
25
26 set(libname "omptarget-amdgcn")
27
28+set(toolchain_deps "")
29+if(TARGET llvm-link)
30+ list(APPEND toolchain_deps llvm-link)
31+endif()
32+if(TARGET opt)
33+ list(APPEND toolchain_deps opt)
34+endif()
35+
36 foreach(mcpu ${mcpus})
37 set(bc_files)
38 add_cuda_bc_library(${cuda_sources})
39@@ -157,7 +165,7 @@ foreach(mcpu ${mcpus})
40 add_custom_command(
41 OUTPUT ${bc_libname}
42 COMMAND ${LINK_TOOL} ${bc_files} | ${OPT_TOOL} --always-inline -o ${OUTPUTDIR}/${bc_libname}
43- DEPENDS ${bc_files} llvm-link opt)
44+ DEPENDS ${bc_files} ${toolchain_deps})
45
46 add_custom_target(lib${libname}-${mcpu} ALL DEPENDS ${bc_libname})
47
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index 8282862..f1bfd19 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -46,8 +46,6 @@ SRC_URI = "\
46 file://0034-compiler-rt-Do-not-force-thumb-mode-directive.patch \ 46 file://0034-compiler-rt-Do-not-force-thumb-mode-directive.patch \
47 file://0035-Drop-the-git-suffix-from-various-version-variables.patch \ 47 file://0035-Drop-the-git-suffix-from-various-version-variables.patch \
48 file://0036-clang-Do-not-use-install-relative-libc-headers.patch \ 48 file://0036-clang-Do-not-use-install-relative-libc-headers.patch \
49 file://D108404.diff \
50 file://D108868.diff \
51 " 49 "
52# Fallback to no-PIE if not set 50# Fallback to no-PIE if not set
53GCCPIE ??= "" 51GCCPIE ??= ""