summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/openmp_git.bb
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2019-02-14 18:42:49 -0600
committerKhem Raj <raj.khem@gmail.com>2020-01-20 08:56:16 -0800
commit269634b393554a5502e47cc0cf9a3f63a5856d45 (patch)
treeaeacca0fcd9352195872459e7b7a5621fd1c0269 /recipes-devtools/clang/openmp_git.bb
parentcda1376a97b86d6ae5c92fd931f9583430c73885 (diff)
downloadmeta-clang-269634b393554a5502e47cc0cf9a3f63a5856d45.tar.gz
clang: stay closer to cmake.bbclass
Allow more of the cmake variables coming from the OE environment through, otherwise the release C flags and CXX flags get reset to LLVM's default, which greatly extend build times. Also switch to using cmake.bbclass's do_compile and do_install commands. There's no need to call ninja directly anymore. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
Diffstat (limited to 'recipes-devtools/clang/openmp_git.bb')
-rw-r--r--recipes-devtools/clang/openmp_git.bb12
1 files changed, 1 insertions, 11 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index 0afbf97..501ee5a 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -8,8 +8,6 @@ SECTION = "libs"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11DEPENDS += "ninja-native"
12
13RPROVIDES_${PN} += "libgomp" 11RPROVIDES_${PN} += "libgomp"
14RPROVIDES_${PN}-dev += "libgomp-dev" 12RPROVIDES_${PN}-dev += "libgomp-dev"
15 13
@@ -19,7 +17,7 @@ LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c
19 17
20inherit cmake pkgconfig perlnative 18inherit cmake pkgconfig perlnative
21 19
22EXTRA_OECMAKE = "-G Ninja ${S}/openmp" 20OECMAKE_SOURCEPATH = "${S}/openmp"
23 21
24PACKAGECONFIG ?= "ompt-tools" 22PACKAGECONFIG ?= "ompt-tools"
25PACKAGECONFIG_remove_arm = "ompt-tools" 23PACKAGECONFIG_remove_arm = "ompt-tools"
@@ -28,14 +26,6 @@ PACKAGECONFIG_remove_powerpc = "ompt-tools"
28 26
29PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF," 27PACKAGECONFIG[ompt-tools] = "-DOPENMP_ENABLE_OMPT_TOOLS=ON,-DOPENMP_ENABLE_OMPT_TOOLS=OFF,"
30 28
31do_compile() {
32 ninja ${PARALLEL_MAKE}
33}
34
35do_install() {
36 DESTDIR=${D} ninja ${PARALLEL_MAKE} install
37}
38
39FILES_SOLIBSDEV = "" 29FILES_SOLIBSDEV = ""
40FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}" 30FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
41INSANE_SKIP_${PN} = "dev-so" 31INSANE_SKIP_${PN} = "dev-so"