summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libcxx_git.bb
diff options
context:
space:
mode:
authorPiotr Tworek <tworaz@tworaz.net>2019-08-17 21:00:51 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-17 12:15:08 -0700
commit8fbef33bfac1a820ee48cbe296b56dfb06d1f0b8 (patch)
treec68b61e2287b32100407eaf664c4104f8afe032d /recipes-devtools/clang/libcxx_git.bb
parenta7d5f278f2c83622f0f744f2c3837f67d5c3f9e1 (diff)
downloadmeta-clang-8fbef33bfac1a820ee48cbe296b56dfb06d1f0b8.tar.gz
libcxx: Add libunwind to PROVIDES not only RPROVIDES.
Without this bitbake will still pull standard libunwind package when building recipes depending on libunwind. If such recipe also happens to pull libcxx the build will fail when assembling the sysroot because both libcxx and libunwind provide libunwind.so. This problem has been observed when building libstd-rs from meta-rust layer agains musl libc. Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
Diffstat (limited to 'recipes-devtools/clang/libcxx_git.bb')
-rw-r--r--recipes-devtools/clang/libcxx_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index dafeccc..7bbe847 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -80,7 +80,7 @@ do_install() {
80 80
81ALLOW_EMPTY_${PN} = "1" 81ALLOW_EMPTY_${PN} = "1"
82 82
83#PROVIDES = "virtual/${TARGET_PREFIX}compilerlibs" 83PROVIDES = "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind', '', d)}"
84RPROVIDES_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind', '', d)}" 84RPROVIDES_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind', '', d)}"
85RPROVIDES_${PN}-dev += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-dev', '', d)}" 85RPROVIDES_${PN}-dev += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-dev', '', d)}"
86RPROVIDES_${PN}-doc += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-doc', '', d)}" 86RPROVIDES_${PN}-doc += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-doc', '', d)}"